aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuta Doi <yuta-d@witz-inc.co.jp>2018-07-11 16:21:37 +0900
committerYuta Doi <yuta-d@witz-inc.co.jp>2018-07-12 00:27:30 +0000
commit67f414f67ee22ddf40003d1be3fa1d0cb13deb8f (patch)
tree407f01c2af124c97f38d79403b808828b6ea527f /CMakeLists.txt
parent99b6f4d2fcd421d3a760a88a67e511fb6fc98068 (diff)
Add policy table generated by ZIPC for EXAMPLEflounder_5.99.2flounder/5.99.25.99.2
To PolicyManager, add the source code of policy table which is generated by ZIPC for EXAMPLE. If use this example, please comment out line 84 and uncomment line 85 in CMakeLists.txt as follows: #set(USE_STM_NAME stub) set(USE_STM_NAME zipc) If try to show split layout, please rename from roles.db.split to roles.db in src/policy_manager/db/. Bug-AGL: SPEC-1537 Change-Id: I4b35f148313e0c5a12c59ed1c2f8eb6fbcf3ea6b Signed-off-by: Yuta Doi <yuta-d@witz-inc.co.jp>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92ee691..b250542 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,6 +82,7 @@ set(LINK_LIBCXX OFF CACHE BOOL "Link against LLVMs libc++")
# Set name of PolicyManager and STM
set(PLUGIN_PM policy_manager)
set(USE_STM_NAME stub)
+#set(USE_STM_NAME zipc)
# Add STM
add_subdirectory(src/${PLUGIN_PM}/stm/${USE_STM_NAME}/src)