aboutsummaryrefslogtreecommitdiffstats
path: root/bindings/tutorials/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-04-30 22:18:08 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-04-30 22:18:08 +0200
commitd00bfe9410cfcaeb247ba68a88144defb5184ac9 (patch)
tree58e4a07e9d7ebad3215122449dc43193078c5ded /bindings/tutorials/CMakeLists.txt
parent5214323d82cc09b15c25e348707f2639977ea763 (diff)
Allow to tune installation directories
The location of intrinsic bindings and samples could not be tuned but was fixed to be ${CMAKE_INSTALL_FULL_LIBDIR}/afb and ${CMAKE_INSTALL_FULL_DATADIR}/af-binder These default locations are not bad but it is important to be able to tune that location. Bug-AGL: SPEC-2367 Change-Id: I4d4f9e9490d61e3278ef35ac42f2143a752a7c37 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'bindings/tutorials/CMakeLists.txt')
-rw-r--r--bindings/tutorials/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/bindings/tutorials/CMakeLists.txt b/bindings/tutorials/CMakeLists.txt
index e071d7a9..a3c87c55 100644
--- a/bindings/tutorials/CMakeLists.txt
+++ b/bindings/tutorials/CMakeLists.txt
@@ -24,7 +24,7 @@ MACRO(tuto num ext)
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
)
TARGET_LINK_LIBRARIES(tuto-${num} ${json-c_LDFLAGS})
- install(TARGETS tuto-${num} LIBRARY DESTINATION ${install_datadir}/bindings/tutorials)
+ install(TARGETS tuto-${num} LIBRARY DESTINATION ${SAMPLE_INSTALL_DIR}/bindings/tutorials)
ENDMACRO(tuto)