aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-26 18:57:24 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-26 19:04:53 +0100
commit3e3a29fa49ec494800a4aa866d84fba4eaa8261b (patch)
treef580666e31bf07f6598bf6a31e08d91026563e66 /src/CMakeLists.txt
parentd1e30006b071533ae2d1903251962d2dec452418 (diff)
afs-supervisor: Add systemd service and config
Change-Id: I64bf8de01dbb8cf9581ed0be358d81fa84106520 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bfe187f5..d7cde903 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -89,13 +89,15 @@ INSTALL(TARGETS afb-daemon
###########################################
# build and install afb-daemon
###########################################
-ADD_EXECUTABLE(afs-supervisor afs-main.c afs-supervisor.c afs-discover.c afs-config.c)
-TARGET_LINK_LIBRARIES(afs-supervisor
- afb-lib
- ${link_libraries}
-)
-INSTALL(TARGETS afs-supervisor
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+IF(INCLUDE_SUPERVISOR)
+ ADD_EXECUTABLE(afs-supervisor afs-main.c afs-supervisor.c afs-discover.c afs-config.c)
+ TARGET_LINK_LIBRARIES(afs-supervisor
+ afb-lib
+ ${link_libraries}
+ )
+ INSTALL(TARGETS afs-supervisor
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ENDIF()
###########################################
# build and install libafbwsc