aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bfe187f5..d7cde903 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -89,13 +89,15 @@ INSTALL(TARGETS afb-daemon
###########################################
# build and install afb-daemon
###########################################
-ADD_EXECUTABLE(afs-supervisor afs-main.c afs-supervisor.c afs-discover.c afs-config.c)
-TARGET_LINK_LIBRARIES(afs-supervisor
- afb-lib
- ${link_libraries}
-)
-INSTALL(TARGETS afs-supervisor
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+IF(INCLUDE_SUPERVISOR)
+ ADD_EXECUTABLE(afs-supervisor afs-main.c afs-supervisor.c afs-discover.c afs-config.c)
+ TARGET_LINK_LIBRARIES(afs-supervisor
+ afb-lib
+ ${link_libraries}
+ )
+ INSTALL(TARGETS afs-supervisor
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ENDIF()
###########################################
# build and install libafbwsc