aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-10-20 10:35:08 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-10-20 12:00:52 +0200
commit62a07cae0e40181daafdb0204c275af66d0f6d64 (patch)
treeb4a6e88e9b5cd12d3f0eba10fcc7d5b06c4d0fa7 /CMakeLists.txt
parent18103e986d89b9e329f49d9329d8bc40dffd39eb (diff)
afm-run: set smack attributes to user directory
The home directory for applications of a user that was created by the daemon also gets a security label and encures that there is no transmutation. It also simplifies allocation of the directory string. Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d649186..3c41f58 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,7 @@ set(afm_icondir "${afm_datadir}/icons" CACHE STRING "Directory for i
set(afm_prefix "urn:AGL:" CACHE STRING "Prefix for uniform resource name")
set(afm_prefix_binding "${afm_prefix}binding:" CACHE STRING "URN for bindings")
set(afm_user_appdir "app-data" CACHE STRING "User subdirectory for applications")
+set(afm_user_appdir_label "User::App-Shared" CACHE STRING "Smack label of the user subdirectory for applications")
set(wgtpkg_trusted_cert_dir "${afm_confdir}/certs" CACHE STRING "Path to internal certificates")
if(USE_SIMULATION)
@@ -58,6 +59,7 @@ add_definitions(
-DFWK_USER_APP_DIR="${afm_user_appdir}"
-DWGTPKG_TRUSTED_CERT_DIR="${wgtpkg_trusted_cert_dir}"
-DFWK_LAUNCH_CONF="${afm_confdir}/afm-launch.conf"
+ -DFWK_USER_APP_DIR_LABEL="${afm_user_appdir_label}"
)
add_subdirectory(src)