aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-05-23 18:38:45 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-06-14 11:17:52 +0200
commitce5c20d2fa7e9c3e08c97643c77c7647bef79cd5 (patch)
treea32821aaa724b3f6770db8d672f228c33e328516 /src/CMakeLists.txt
parent5b801a3e7b0465f88b785a155dd430ba09c56568 (diff)
afm-user-daemon: Remove it by default
The daemon afm-user-daemon is deprecated. To be cleaner, it is removed from the compilation and the installation. It is still kept a again for little time in the unexpected case where it could be useful to compile it. Bug-AGL: SPEC-2437 Change-Id: Ifccee49eb14ceff5f7a78fb299260918a585bf93 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2346db0..b112d55 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -170,9 +170,11 @@ if(libsystemd_FOUND AND AFB_FOUND)
add_library(jbus STATIC utils-jbus.c)
- add_executable(afm-user-daemon afm-user-daemon.c)
- target_link_libraries(afm-user-daemon jbus utils)
- install(TARGETS afm-user-daemon DESTINATION ${CMAKE_INSTALL_BINDIR})
+ if(LEGACY_USER_DAEMON)
+ add_executable(afm-user-daemon afm-user-daemon.c)
+ target_link_libraries(afm-user-daemon jbus utils)
+ install(TARGETS afm-user-daemon DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
add_library(afm-binding MODULE afm-binding.c)
target_link_libraries(afm-binding wgtpkg wgt secwrp utils afm)