aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2346db0..b112d55 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -170,9 +170,11 @@ if(libsystemd_FOUND AND AFB_FOUND)
add_library(jbus STATIC utils-jbus.c)
- add_executable(afm-user-daemon afm-user-daemon.c)
- target_link_libraries(afm-user-daemon jbus utils)
- install(TARGETS afm-user-daemon DESTINATION ${CMAKE_INSTALL_BINDIR})
+ if(LEGACY_USER_DAEMON)
+ add_executable(afm-user-daemon afm-user-daemon.c)
+ target_link_libraries(afm-user-daemon jbus utils)
+ install(TARGETS afm-user-daemon DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
add_library(afm-binding MODULE afm-binding.c)
target_link_libraries(afm-binding wgtpkg wgt secwrp utils afm)