aboutsummaryrefslogtreecommitdiffstats
path: root/afb-source/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-08-23 01:12:46 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-12-13 15:02:04 +0100
commit7abfae473d9ecbc7ac5074ef4c443e11852f7c3c (patch)
tree2e9908b324c67d888ee2bd84ee93221fd316eb61 /afb-source/CMakeLists.txt
parent4921883434749752ac82a0cbab8e6e57120800c5 (diff)
Moved Sample Plugin in an independant directory
Diffstat (limited to 'afb-source/CMakeLists.txt')
-rw-r--r--afb-source/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/afb-source/CMakeLists.txt b/afb-source/CMakeLists.txt
index 4c1ea66..cfbd4f7 100644
--- a/afb-source/CMakeLists.txt
+++ b/afb-source/CMakeLists.txt
@@ -41,33 +41,3 @@ PROJECT_TARGET_ADD(control-afb)
LINK_FLAGS ${BINDINGS_LINK_FLAG}
OUTPUT_NAME ${TARGET_NAME}
)
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- afb-utilities
- ${link_libraries}
- )
-
-
-PROJECT_TARGET_ADD(audio-plugin-sample)
-
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE ctl-plugin-sample.c)
-
- # Alsa Plugin properties
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ${CTL_PLUGIN_PRE}
- SUFFIX ${CTL_PLUGIN_EXT}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- afb-utilities
- ${link_libraries}
- )
-
- # installation directory
- INSTALL(TARGETS ${TARGET_NAME}
- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/${PROJECT_NAME}/lib/controller-plugins)
-