summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-03-30 13:15:29 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-05-11 00:55:42 -0700
commitc26cadd532d98f59f0d53c6337d23f824593754c (patch)
treefdd71d9d4d6d616886cba4ae56f0ab10ffdf9619 /CMakeLists.txt
parent62a76f993bfbfb80dd8878239bec1647c54cd626 (diff)
libqtappfw: mediaplayer: initial agl-service-mediaplayer binding supporteel_5.1.0eel_5.0.3eel/5.1.0eel/5.0.35.1.05.0.3eel
Add initial support interface between agl-service-mediaplayer and libqtappfw Bug-AGL: SPEC-1375 Change-Id: I740d8cddfd73198b7a3246cb46c941da9f3175d1 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a3f5dcf..b9124ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,12 +16,13 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw.pc
add_library(qtappfw SHARED message.cpp messageengine.cpp
bluetooth.cpp bluetoothmessage.cpp
- telephony.cpp telephonymessage.cpp)
+ telephony.cpp telephonymessage.cpp
+ mediaplayer.cpp mediaplayermessage.cpp)
target_link_libraries(qtappfw Qt5::WebSockets)
set_target_properties(qtappfw PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1
- PUBLIC_HEADER "message.h;messageengine.h;bluetooth.h;bluetoothmessage.h;telephony.h;telephonymessage.h")
+ PUBLIC_HEADER "message.h;messageengine.h;mediaplayer.h;mediaplayermessage.h;bluetooth.h;bluetoothmessage.h;telephony.h;telephonymessage.h")
target_include_directories(qtappfw PRIVATE .)
install(TARGETS qtappfw
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}