summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a3f5dcf..b9124ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,12 +16,13 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw.pc
add_library(qtappfw SHARED message.cpp messageengine.cpp
bluetooth.cpp bluetoothmessage.cpp
- telephony.cpp telephonymessage.cpp)
+ telephony.cpp telephonymessage.cpp
+ mediaplayer.cpp mediaplayermessage.cpp)
target_link_libraries(qtappfw Qt5::WebSockets)
set_target_properties(qtappfw PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1
- PUBLIC_HEADER "message.h;messageengine.h;bluetooth.h;bluetoothmessage.h;telephony.h;telephonymessage.h")
+ PUBLIC_HEADER "message.h;messageengine.h;mediaplayer.h;mediaplayermessage.h;bluetooth.h;bluetoothmessage.h;telephony.h;telephonymessage.h")
target_include_directories(qtappfw PRIVATE .)
install(TARGETS qtappfw
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}