summaryrefslogtreecommitdiffstats
path: root/hvac/meson.build
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:46 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:56 +0100
commit4f75c049e8ba1e7fd4f1094f9ed8b681318f021d (patch)
treeaa98230ff962aeba9775c459515b229c8eac47a0 /hvac/meson.build
parent1d78b4a6f9ba4807901c6fc30ece2b84754908e8 (diff)
Import Qt6 conversion patchHEADmaster
Import the patches for the demo applications into the app repos. Bug-AGL: SPEC-5294 Change-Id: I516a951cdd49dbfb1729bf4e49360333b951bad3 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'hvac/meson.build')
-rw-r--r--hvac/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/hvac/meson.build b/hvac/meson.build
index ce3679c..ad41612 100644
--- a/hvac/meson.build
+++ b/hvac/meson.build
@@ -1,14 +1,14 @@
-qt5_dep = dependency('qt5', modules: ['Qml'])
+qt_dep = dependency('qt6', modules: ['Qml'])
-moc_files = qt5.compile_moc(headers: 'hvac.h',
- dependencies: qt5_dep)
+moc_files = qt.compile_moc(headers: 'hvac.h',
+ dependencies: qt_dep)
src = ['hvac.cpp', moc_files]
lib = shared_library('qtappfw-hvac',
sources: src,
version: '1.0.0',
soversion: '0',
- dependencies: [qt5_dep, qtappfw_vs_dep],
+ dependencies: [qt_dep, qtappfw_vs_dep],
install: true)
install_headers('hvac.h')
@@ -18,5 +18,5 @@ pkg_mod.generate(libraries : lib,
version : '1.0',
name : 'libqtappfw-hvac',
filebase : 'qtappfw-hvac',
- requires: 'Qt5Qml',
+ requires: 'Qt6Qml',
description : 'AGL Qt demo app framework helper library for using HVAC.')