summaryrefslogtreecommitdiffstats
path: root/hvac/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hvac/meson.build')
-rw-r--r--hvac/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/hvac/meson.build b/hvac/meson.build
index ce3679c..ad41612 100644
--- a/hvac/meson.build
+++ b/hvac/meson.build
@@ -1,14 +1,14 @@
-qt5_dep = dependency('qt5', modules: ['Qml'])
+qt_dep = dependency('qt6', modules: ['Qml'])
-moc_files = qt5.compile_moc(headers: 'hvac.h',
- dependencies: qt5_dep)
+moc_files = qt.compile_moc(headers: 'hvac.h',
+ dependencies: qt_dep)
src = ['hvac.cpp', moc_files]
lib = shared_library('qtappfw-hvac',
sources: src,
version: '1.0.0',
soversion: '0',
- dependencies: [qt5_dep, qtappfw_vs_dep],
+ dependencies: [qt_dep, qtappfw_vs_dep],
install: true)
install_headers('hvac.h')
@@ -18,5 +18,5 @@ pkg_mod.generate(libraries : lib,
version : '1.0',
name : 'libqtappfw-hvac',
filebase : 'qtappfw-hvac',
- requires: 'Qt5Qml',
+ requires: 'Qt6Qml',
description : 'AGL Qt demo app framework helper library for using HVAC.')