summaryrefslogtreecommitdiffstats
path: root/network/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-01-28 16:54:55 -0500
committerScott Murray <scott.murray@konsulko.com>2022-01-28 17:00:09 -0500
commit5ef90db242ad29c9772f2237b477c58ef65545c7 (patch)
treef9b7b2e56a0aaec37bb9ef99faa316465613b941 /network/CMakeLists.txt
parent0fee9bfb0f656b78f34c44542329760be2980892 (diff)
Re-enable network supportmarlin_12.92.0marlin/12.92.012.92.0
Rework network support code to use new connman-glib library instead of the previously disabled agl-service-network API. The only user visible change is that a few extra previously exported header files have been pruned from installation to avoid exposing GLib usage and potentially requiring users needing to build against it. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Iab8f3c9d04ee603e06b80dfd92ac03d9d52af477
Diffstat (limited to 'network/CMakeLists.txt')
-rw-r--r--network/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/network/CMakeLists.txt b/network/CMakeLists.txt
index b7ae7a1..6627a68 100644
--- a/network/CMakeLists.txt
+++ b/network/CMakeLists.txt
@@ -4,6 +4,7 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-network.pc
DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
add_library(qtappfw-network SHARED network.cpp
+ networkeventhandler.cpp
wifiadapter.cpp
wiredadapter.cpp
wifinetworkmodel.cpp
@@ -14,11 +15,11 @@ add_library(qtappfw-network SHARED network.cpp
target_include_directories(qtappfw-network PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
target_include_directories(qtappfw-network PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-target_link_libraries(qtappfw-network Qt5::Qml)
+target_link_libraries(qtappfw-network Qt5::Qml PkgConfig::glib PkgConfig::connman_glib)
set_target_properties(qtappfw-network PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1
- PUBLIC_HEADER "network.h;networkadapter.h;wifiadapter.h;wiredadapter.h;wifinetworkmodel.h;wirednetworkmodel.h;abstractnetworkmodel.h;connectionprofile.h")
+ PUBLIC_HEADER "network.h;networkadapter.h;wifiadapter.h;wiredadapter.h")
install(TARGETS qtappfw-network
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}