summaryrefslogtreecommitdiffstats
path: root/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'network/CMakeLists.txt')
-rw-r--r--network/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/network/CMakeLists.txt b/network/CMakeLists.txt
index b7ae7a1..6627a68 100644
--- a/network/CMakeLists.txt
+++ b/network/CMakeLists.txt
@@ -4,6 +4,7 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-network.pc
DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
add_library(qtappfw-network SHARED network.cpp
+ networkeventhandler.cpp
wifiadapter.cpp
wiredadapter.cpp
wifinetworkmodel.cpp
@@ -14,11 +15,11 @@ add_library(qtappfw-network SHARED network.cpp
target_include_directories(qtappfw-network PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
target_include_directories(qtappfw-network PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-target_link_libraries(qtappfw-network Qt5::Qml)
+target_link_libraries(qtappfw-network Qt5::Qml PkgConfig::glib PkgConfig::connman_glib)
set_target_properties(qtappfw-network PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1
- PUBLIC_HEADER "network.h;networkadapter.h;wifiadapter.h;wiredadapter.h;wifinetworkmodel.h;wirednetworkmodel.h;abstractnetworkmodel.h;connectionprofile.h")
+ PUBLIC_HEADER "network.h;networkadapter.h;wifiadapter.h;wiredadapter.h")
install(TARGETS qtappfw-network
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}