aboutsummaryrefslogtreecommitdiffstats
path: root/hw/9pfs/meson.build
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
committerTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
commite02cda008591317b1625707ff8e115a4841aa889 (patch)
treeaee302e3cf8b59ec2d32ec481be3d1afddfc8968 /hw/9pfs/meson.build
parentcc668e6b7e0ffd8c9d130513d12053cf5eda1d3b (diff)
Introduce Virtio-loopback epsilon release:
Epsilon release introduces a new compatibility layer which make virtio-loopback design to work with QEMU and rust-vmm vhost-user backend without require any changes. Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com> Change-Id: I52e57563e08a7d0bdc002f8e928ee61ba0c53dd9
Diffstat (limited to 'hw/9pfs/meson.build')
-rw-r--r--hw/9pfs/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/hw/9pfs/meson.build b/hw/9pfs/meson.build
new file mode 100644
index 000000000..99be5d911
--- /dev/null
+++ b/hw/9pfs/meson.build
@@ -0,0 +1,20 @@
+fs_ss = ss.source_set()
+fs_ss.add(files(
+ '9p-local.c',
+ '9p-posix-acl.c',
+ '9p-proxy.c',
+ '9p-synth.c',
+ '9p-util.c',
+ '9p-xattr-user.c',
+ '9p-xattr.c',
+ '9p.c',
+ 'codir.c',
+ 'cofile.c',
+ 'cofs.c',
+ 'coth.c',
+ 'coxattr.c',
+))
+fs_ss.add(when: 'CONFIG_XEN', if_true: files('xen-9p-backend.c'))
+softmmu_ss.add_all(when: 'CONFIG_FSDEV_9P', if_true: fs_ss)
+
+specific_ss.add(when: 'CONFIG_VIRTIO_9P', if_true: files('virtio-9p-device.c'))