aboutsummaryrefslogtreecommitdiffstats
path: root/hw/9pfs/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/9pfs/meson.build')
-rw-r--r--hw/9pfs/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/hw/9pfs/meson.build b/hw/9pfs/meson.build
new file mode 100644
index 000000000..99be5d911
--- /dev/null
+++ b/hw/9pfs/meson.build
@@ -0,0 +1,20 @@
+fs_ss = ss.source_set()
+fs_ss.add(files(
+ '9p-local.c',
+ '9p-posix-acl.c',
+ '9p-proxy.c',
+ '9p-synth.c',
+ '9p-util.c',
+ '9p-xattr-user.c',
+ '9p-xattr.c',
+ '9p.c',
+ 'codir.c',
+ 'cofile.c',
+ 'cofs.c',
+ 'coth.c',
+ 'coxattr.c',
+))
+fs_ss.add(when: 'CONFIG_XEN', if_true: files('xen-9p-backend.c'))
+softmmu_ss.add_all(when: 'CONFIG_FSDEV_9P', if_true: fs_ss)
+
+specific_ss.add(when: 'CONFIG_VIRTIO_9P', if_true: files('virtio-9p-device.c'))