aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/fortran/1 basic/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/fortran/1 basic/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/fortran/1 basic/meson.build')
-rw-r--r--meson/test cases/fortran/1 basic/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson/test cases/fortran/1 basic/meson.build b/meson/test cases/fortran/1 basic/meson.build
new file mode 100644
index 000000000..52e2d6f05
--- /dev/null
+++ b/meson/test cases/fortran/1 basic/meson.build
@@ -0,0 +1,13 @@
+project('simple fortran', 'fortran')
+
+fc = meson.get_compiler('fortran')
+if fc.get_id() == 'gcc'
+ add_global_arguments('-fbounds-check', language : 'fortran')
+endif
+
+args = fc.first_supported_argument(['-ffree-form', '-free', '/free'])
+assert(args != [], 'No arguments found?')
+
+e = executable('simple', 'simple.f90',
+ fortran_args : args)
+test('Simple Fortran', e)