aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/fortran/1 basic/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/fortran/1 basic/meson.build')
-rw-r--r--meson/test cases/fortran/1 basic/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson/test cases/fortran/1 basic/meson.build b/meson/test cases/fortran/1 basic/meson.build
new file mode 100644
index 000000000..52e2d6f05
--- /dev/null
+++ b/meson/test cases/fortran/1 basic/meson.build
@@ -0,0 +1,13 @@
+project('simple fortran', 'fortran')
+
+fc = meson.get_compiler('fortran')
+if fc.get_id() == 'gcc'
+ add_global_arguments('-fbounds-check', language : 'fortran')
+endif
+
+args = fc.first_supported_argument(['-ffree-form', '-free', '/free'])
+assert(args != [], 'No arguments found?')
+
+e = executable('simple', 'simple.f90',
+ fortran_args : args)
+test('Simple Fortran', e)