aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/vala/15 static vapi in source tree/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/vala/15 static vapi in source tree/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/vala/15 static vapi in source tree/meson.build')
-rw-r--r--meson/test cases/vala/15 static vapi in source tree/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson/test cases/vala/15 static vapi in source tree/meson.build b/meson/test cases/vala/15 static vapi in source tree/meson.build
new file mode 100644
index 000000000..44bea484a
--- /dev/null
+++ b/meson/test cases/vala/15 static vapi in source tree/meson.build
@@ -0,0 +1,13 @@
+project('static vapi', 'c', 'vala')
+
+glib = dependency('glib-2.0')
+
+conf = configuration_data()
+conf.set_quoted('VERSION', '1.0.0')
+config_h = configure_file(output : 'config.h',
+ configuration : conf)
+
+e = executable('static-vapi', 'vapi/config.vapi', 'test.vala',
+ dependencies : glib)
+
+test('test-config', e)