aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/vala/15 static vapi in source tree/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/vala/15 static vapi in source tree/meson.build')
-rw-r--r--meson/test cases/vala/15 static vapi in source tree/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson/test cases/vala/15 static vapi in source tree/meson.build b/meson/test cases/vala/15 static vapi in source tree/meson.build
new file mode 100644
index 000000000..44bea484a
--- /dev/null
+++ b/meson/test cases/vala/15 static vapi in source tree/meson.build
@@ -0,0 +1,13 @@
+project('static vapi', 'c', 'vala')
+
+glib = dependency('glib-2.0')
+
+conf = configuration_data()
+conf.set_quoted('VERSION', '1.0.0')
+config_h = configure_file(output : 'config.h',
+ configuration : conf)
+
+e = executable('static-vapi', 'vapi/config.vapi', 'test.vala',
+ dependencies : glib)
+
+test('test-config', e)