aboutsummaryrefslogtreecommitdiffstats
path: root/subprojects/libvhost-user/meson.build
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
committerTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
commite02cda008591317b1625707ff8e115a4841aa889 (patch)
treeaee302e3cf8b59ec2d32ec481be3d1afddfc8968 /subprojects/libvhost-user/meson.build
parentcc668e6b7e0ffd8c9d130513d12053cf5eda1d3b (diff)
Introduce Virtio-loopback epsilon release:
Epsilon release introduces a new compatibility layer which make virtio-loopback design to work with QEMU and rust-vmm vhost-user backend without require any changes. Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com> Change-Id: I52e57563e08a7d0bdc002f8e928ee61ba0c53dd9
Diffstat (limited to 'subprojects/libvhost-user/meson.build')
-rw-r--r--subprojects/libvhost-user/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/subprojects/libvhost-user/meson.build b/subprojects/libvhost-user/meson.build
new file mode 100644
index 000000000..39825d940
--- /dev/null
+++ b/subprojects/libvhost-user/meson.build
@@ -0,0 +1,23 @@
+project('libvhost-user', 'c',
+ license: 'GPL-2.0-or-later',
+ default_options: ['c_std=gnu99'])
+
+threads = dependency('threads')
+glib = dependency('glib-2.0')
+
+vhost_user = static_library('vhost-user',
+ files('libvhost-user.c'),
+ dependencies: threads,
+ c_args: '-D_GNU_SOURCE')
+
+executable('link-test', files('link-test.c'),
+ link_whole: vhost_user)
+
+vhost_user_glib = static_library('vhost-user-glib',
+ files('libvhost-user-glib.c'),
+ link_with: vhost_user,
+ dependencies: glib)
+
+vhost_user_dep = declare_dependency(link_with: vhost_user_glib,
+ dependencies: glib,
+ include_directories: include_directories('.'))