aboutsummaryrefslogtreecommitdiffstats
path: root/subprojects/libvhost-user/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/libvhost-user/meson.build')
-rw-r--r--subprojects/libvhost-user/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/subprojects/libvhost-user/meson.build b/subprojects/libvhost-user/meson.build
new file mode 100644
index 000000000..39825d940
--- /dev/null
+++ b/subprojects/libvhost-user/meson.build
@@ -0,0 +1,23 @@
+project('libvhost-user', 'c',
+ license: 'GPL-2.0-or-later',
+ default_options: ['c_std=gnu99'])
+
+threads = dependency('threads')
+glib = dependency('glib-2.0')
+
+vhost_user = static_library('vhost-user',
+ files('libvhost-user.c'),
+ dependencies: threads,
+ c_args: '-D_GNU_SOURCE')
+
+executable('link-test', files('link-test.c'),
+ link_whole: vhost_user)
+
+vhost_user_glib = static_library('vhost-user-glib',
+ files('libvhost-user-glib.c'),
+ link_with: vhost_user,
+ dependencies: glib)
+
+vhost_user_dep = declare_dependency(link_with: vhost_user_glib,
+ dependencies: glib,
+ include_directories: include_directories('.'))