aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch')
-rw-r--r--meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch b/meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch
new file mode 100644
index 0000000..49f2872
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index affaa30..ad539ca 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,7 +12,6 @@ SET(VERSION 1.0)
+ # Common Options
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -O2 -omit-frame-pointer -std=gnu++0x")
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fdata-sections -ffunction-sections")
+-SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--gc-section -Wl,--print-gc-section")
+ MESSAGE("FLAGS: ${CMAKE_CXX_FLAGS}")
+ MESSAGE("FLAGS: ${CMAKE_EXE_LINKER_FLAGS}")
+
+--
+1.9.1
+