aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-others/sensord
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-others/sensord')
-rw-r--r--meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch15
-rw-r--r--meta-application-manager/recipes-others/sensord/files/0002-Fix-libinstalldir.patch219
-rw-r--r--meta-application-manager/recipes-others/sensord/files/0003-remove_checking_libsystemd-daemon.patch13
-rw-r--r--meta-application-manager/recipes-others/sensord/files/0004-Removing-redundant-auto_rotation-events.patch117
-rw-r--r--meta-application-manager/recipes-others/sensord/sensord-extraconf.inc5
-rw-r--r--meta-application-manager/recipes-others/sensord/sensord.inc189
-rw-r--r--meta-application-manager/recipes-others/sensord/sensord_git.bb10
7 files changed, 568 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch b/meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch
new file mode 100644
index 0000000..49f2872
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/files/0001-remove-linkerflags.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index affaa30..ad539ca 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,7 +12,6 @@ SET(VERSION 1.0)
+ # Common Options
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -O2 -omit-frame-pointer -std=gnu++0x")
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fdata-sections -ffunction-sections")
+-SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--gc-section -Wl,--print-gc-section")
+ MESSAGE("FLAGS: ${CMAKE_CXX_FLAGS}")
+ MESSAGE("FLAGS: ${CMAKE_EXE_LINKER_FLAGS}")
+
+--
+1.9.1
+
diff --git a/meta-application-manager/recipes-others/sensord/files/0002-Fix-libinstalldir.patch b/meta-application-manager/recipes-others/sensord/files/0002-Fix-libinstalldir.patch
new file mode 100644
index 0000000..ce0bb47
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/files/0002-Fix-libinstalldir.patch
@@ -0,0 +1,219 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ad539ca..5cd0bea 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,7 +5,7 @@ include(GNUInstallDirs)
+ # Setup For pkgconfig File
+ SET(PREFIX ${CMAKE_INSTALL_PREFIX})
+ SET(EXEC_PREFIX "${PREFIX}/bin")
+-SET(LIBDIR "${PREFIX}/${CMAKE_INSTALL_LIBDIR}")
++SET(LIBDIR "${PREFIX}/lib")
+ SET(INCLUDEDIR "${PREFIX}/${CMAKE_INSTALL_INCLUDEDIR}")
+ SET(VERSION 1.0)
+
+@@ -16,7 +16,7 @@ MESSAGE("FLAGS: ${CMAKE_CXX_FLAGS}")
+ MESSAGE("FLAGS: ${CMAKE_EXE_LINKER_FLAGS}")
+
+ add_definitions(-DUSE_DLOG_LOG)
+-add_definitions(-DLIBDIR="${CMAKE_INSTALL_LIBDIR}")
++add_definitions(-DLIBDIR="${LIBDIR}")
+
+ # Internal Debugging Options
+ #add_definitions(-Wall -g -D_DEBUG)
+diff --git a/src/accel/CMakeLists.txt b/src/accel/CMakeLists.txt
+index a37c89c..2f98f37 100755
+--- a/src/accel/CMakeLists.txt
++++ b/src/accel/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${accel_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${accel_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/auto_rotation/CMakeLists.txt b/src/auto_rotation/CMakeLists.txt
+index a0076b2..121c265 100644
+--- a/src/auto_rotation/CMakeLists.txt
++++ b/src/auto_rotation/CMakeLists.txt
+@@ -25,4 +25,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${auto_rot_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/geo/CMakeLists.txt b/src/geo/CMakeLists.txt
+index c6d4aa1..0c593c5 100755
+--- a/src/geo/CMakeLists.txt
++++ b/src/geo/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${geo_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${geo_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/gravity/CMakeLists.txt b/src/gravity/CMakeLists.txt
+index e66964e..69ae097 100755
+--- a/src/gravity/CMakeLists.txt
++++ b/src/gravity/CMakeLists.txt
+@@ -23,4 +23,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${gravity_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/gyro/CMakeLists.txt b/src/gyro/CMakeLists.txt
+index 228fac9..f2ce149 100755
+--- a/src/gyro/CMakeLists.txt
++++ b/src/gyro/CMakeLists.txt
+@@ -28,5 +28,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${gyro_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${gyro_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/libsensord/CMakeLists.txt b/src/libsensord/CMakeLists.txt
+index 5b57251..f507c93 100755
+--- a/src/libsensord/CMakeLists.txt
++++ b/src/libsensord/CMakeLists.txt
+@@ -34,7 +34,7 @@ SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES SOVERSION ${VERSION_MAJOR})
+ SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES VERSION ${VERSION})
+
+ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_SOURCE_DIR}/${PROJECT_NAME}.pc @ONLY)
+-install(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries)
++install(TARGETS ${PROJECT_NAME} DESTINATION ${LIBDIR} COMPONENT RuntimeLibraries)
+ install(FILES sensor.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_internal_deprecated.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_internal.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+@@ -59,4 +59,4 @@ install(FILES sensor_rv.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_temperature.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_motion.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_deprecated.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+-install(FILES ${PROJECT_NAME}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++install(FILES ${PROJECT_NAME}.pc DESTINATION ${LIBDIR}/pkgconfig)
+diff --git a/src/light/CMakeLists.txt b/src/light/CMakeLists.txt
+index 099ff82..759cba7 100755
+--- a/src/light/CMakeLists.txt
++++ b/src/light/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${light_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${light_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/linear_accel/CMakeLists.txt b/src/linear_accel/CMakeLists.txt
+index 986fb11..52a573a 100755
+--- a/src/linear_accel/CMakeLists.txt
++++ b/src/linear_accel/CMakeLists.txt
+@@ -24,4 +24,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${linear_accel_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/orientation/CMakeLists.txt b/src/orientation/CMakeLists.txt
+index 6f02e9a..e7ef28a 100755
+--- a/src/orientation/CMakeLists.txt
++++ b/src/orientation/CMakeLists.txt
+@@ -24,4 +24,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${orientation_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/pressure/CMakeLists.txt b/src/pressure/CMakeLists.txt
+index e61aca4..9eb8df8 100755
+--- a/src/pressure/CMakeLists.txt
++++ b/src/pressure/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${pressure_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${pressure_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/proxi/CMakeLists.txt b/src/proxi/CMakeLists.txt
+index 7cd4517..e05cc43 100755
+--- a/src/proxi/CMakeLists.txt
++++ b/src/proxi/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${proxi_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${proxi_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/rotation_vector/rv/CMakeLists.txt b/src/rotation_vector/rv/CMakeLists.txt
+index d26d4f9..6e0e386 100755
+--- a/src/rotation_vector/rv/CMakeLists.txt
++++ b/src/rotation_vector/rv/CMakeLists.txt
+@@ -24,4 +24,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${rv_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/rotation_vector/rv_raw/CMakeLists.txt b/src/rotation_vector/rv_raw/CMakeLists.txt
+index 223b8c8..e83a639 100755
+--- a/src/rotation_vector/rv_raw/CMakeLists.txt
++++ b/src/rotation_vector/rv_raw/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${rv_raw_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${rv_raw_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/sensor_fusion/CMakeLists.txt b/src/sensor_fusion/CMakeLists.txt
+index c38f410..526b396 100755
+--- a/src/sensor_fusion/CMakeLists.txt
++++ b/src/sensor_fusion/CMakeLists.txt
+@@ -35,4 +35,4 @@ add_library(${SENSOR_FUSION_NAME} SHARED
+
+ target_link_libraries(${SENSOR_FUSION_NAME} ${rpkgs_LDFLAGS} ${GLES_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_FUSION_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_FUSION_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/shared/CMakeLists.txt b/src/shared/CMakeLists.txt
+index f400944..3b37bb6 100755
+--- a/src/shared/CMakeLists.txt
++++ b/src/shared/CMakeLists.txt
+@@ -51,10 +51,10 @@ target_link_libraries(sensord-share ${shared_pkgs_LDFLAGS} "-lrt -ldl -pthread")
+ configure_file(sensord-server.pc.in ${CMAKE_CURRENT_SOURCE_DIR}/sensord-server.pc @ONLY)
+ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_SOURCE_DIR}/${PROJECT_NAME}.pc @ONLY)
+
+-install(TARGETS sensord-server DESTINATION ${CMAKE_INSTALL_LIBDIR})
+-install(TARGETS sensord-share DESTINATION ${CMAKE_INSTALL_LIBDIR})
+-install(FILES sensord-server.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+-install(FILES ${PROJECT_NAME}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++install(TARGETS sensord-server DESTINATION ${LIBDIR})
++install(TARGETS sensord-share DESTINATION ${LIBDIR})
++install(FILES sensord-server.pc DESTINATION ${LIBDIR}/pkgconfig)
++install(FILES ${PROJECT_NAME}.pc DESTINATION ${LIBDIR}/pkgconfig)
+ install(FILES
+ crw_lock.h
+ worker_thread.h
+diff --git a/src/temperature/CMakeLists.txt b/src/temperature/CMakeLists.txt
+index 87dab53..26e03c9 100755
+--- a/src/temperature/CMakeLists.txt
++++ b/src/temperature/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${temp_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${temp_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+--
+1.9.1
+
diff --git a/meta-application-manager/recipes-others/sensord/files/0003-remove_checking_libsystemd-daemon.patch b/meta-application-manager/recipes-others/sensord/files/0003-remove_checking_libsystemd-daemon.patch
new file mode 100644
index 0000000..4039f3d
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/files/0003-remove_checking_libsystemd-daemon.patch
@@ -0,0 +1,13 @@
+diff --git a/src/server/CMakeLists.txt b/src/server/CMakeLists.txt
+index a404c76..941f56b 100755
+--- a/src/server/CMakeLists.txt
++++ b/src/server/CMakeLists.txt
+@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.6)
+ project(sensord CXX)
+
+ INCLUDE(FindPkgConfig)
+-PKG_CHECK_MODULES(server_pkgs REQUIRED vconf glib-2.0 gio-2.0 dlog libsystemd-daemon)
++PKG_CHECK_MODULES(server_pkgs REQUIRED vconf glib-2.0 gio-2.0 dlog libsystemd)
+
+ FOREACH(flag ${server_pkgs_LDFLAGS})
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${flag}")
diff --git a/meta-application-manager/recipes-others/sensord/files/0004-Removing-redundant-auto_rotation-events.patch b/meta-application-manager/recipes-others/sensord/files/0004-Removing-redundant-auto_rotation-events.patch
new file mode 100644
index 0000000..16c64b0
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/files/0004-Removing-redundant-auto_rotation-events.patch
@@ -0,0 +1,117 @@
+From a6689f5545620ae9c050db2de30f432838fb9354 Mon Sep 17 00:00:00 2001
+From: Ankur <ankur29.garg@samsung.com>
+Date: Thu, 26 Feb 2015 17:30:27 +0530
+Subject: [PATCH] Removing redundant auto_rotation events
+
+AUTO_ROTATION_BASE_DATA_SET and AUTO_ROTATION_EVENT_CHANGE_STATE were the same
+AUTO_ROTATION_BASE_DATA_SET has been removed.
+
+AUTO_ROTATION_BASE_DATA_SET was used for polling events and AUTO_ROTATION__EVENT_CHANGE_STATE was used for event driven
+Since both these represent the same auto_rotation sensor event, DATA_SET type has been removed.
+
+And AUTO_ROTATION_EVENT_CHANGE_STATE has been renamed to AUTO_ROTATION_CHANGE_STATE_EVENT to make it simpler.
+
+Change-Id: I8523af6c00dd2919bb6b9f0606c48d5df37ff0c9
+---
+ src/auto_rotation/auto_rotation_sensor.cpp | 6 +++---
+ src/libsensord/client_common.cpp | 5 ++---
+ src/libsensord/sensor_auto_rotation.h | 6 +-----
+ src/libsensord/sensor_deprecated.h | 3 +++
+ 4 files changed, 9 insertions(+), 11 deletions(-)
+
+diff --git a/src/auto_rotation/auto_rotation_sensor.cpp b/src/auto_rotation/auto_rotation_sensor.cpp
+index cdf7609..381e861 100755
+--- a/src/auto_rotation/auto_rotation_sensor.cpp
++++ b/src/auto_rotation/auto_rotation_sensor.cpp
+@@ -49,7 +49,7 @@ auto_rotation_sensor::auto_rotation_sensor()
+ {
+ m_name = string(SENSOR_NAME);
+
+- register_supported_event(AUTO_ROTATION_EVENT_CHANGE_STATE);
++ register_supported_event(AUTO_ROTATION_CHANGE_STATE_EVENT);
+ }
+
+ auto_rotation_sensor::~auto_rotation_sensor()
+@@ -146,7 +146,7 @@ void auto_rotation_sensor::synthesize(const sensor_event_t& event, vector<sensor
+ INFO("Rotation: %d, ACC[0]: %f, ACC[1]: %f, ACC[2]: %f", rotation, event.data.values[0], event.data.values[1], event.data.values[2]);
+ rotation_event.sensor_id = get_id();
+ rotation_event.data.accuracy = SENSOR_ACCURACY_GOOD;
+- rotation_event.event_type = AUTO_ROTATION_EVENT_CHANGE_STATE;
++ rotation_event.event_type = AUTO_ROTATION_CHANGE_STATE_EVENT;
+ rotation_event.data.timestamp = event.data.timestamp;
+ rotation_event.data.values[0] = rotation;
+ rotation_event.data.value_count = 1;
+@@ -161,7 +161,7 @@ void auto_rotation_sensor::synthesize(const sensor_event_t& event, vector<sensor
+
+ int auto_rotation_sensor::get_sensor_data(unsigned int data_id, sensor_data_t &data)
+ {
+- if (data_id != AUTO_ROTATION_BASE_DATA_SET)
++ if (data_id != AUTO_ROTATION_CHANGE_STATE_EVENT)
+ return -1;
+
+ AUTOLOCK(m_value_mutex);
+diff --git a/src/libsensord/client_common.cpp b/src/libsensord/client_common.cpp
+index 361351b..6e5bfe7 100755
+--- a/src/libsensord/client_common.cpp
++++ b/src/libsensord/client_common.cpp
+@@ -48,7 +48,7 @@ log_element g_log_elements[] = {
+ FILL_LOG_ELEMENT(LOG_ID_EVENT, PROXIMITY_EVENT_STATE_REPORT_ON_TIME, 0, 10),
+ FILL_LOG_ELEMENT(LOG_ID_EVENT, PROXIMITY_EVENT_DISTANCE_DATA_REPORT_ON_TIME, 0, 10),
+ FILL_LOG_ELEMENT(LOG_ID_EVENT, CONTEXT_EVENT_REPORT, 0, 1),
+- FILL_LOG_ELEMENT(LOG_ID_EVENT, AUTO_ROTATION_EVENT_CHANGE_STATE, 0, 1),
++ FILL_LOG_ELEMENT(LOG_ID_EVENT, AUTO_ROTATION_CHANGE_STATE_EVENT, 0, 1),
+ FILL_LOG_ELEMENT(LOG_ID_EVENT, ACCELEROMETER_EVENT_RAW_DATA_REPORT_ON_TIME, 0, 10),
+ FILL_LOG_ELEMENT(LOG_ID_EVENT, GYROSCOPE_EVENT_RAW_DATA_REPORT_ON_TIME, 0, 10),
+ FILL_LOG_ELEMENT(LOG_ID_EVENT, GEOMAGNETIC_EVENT_RAW_DATA_REPORT_ON_TIME, 0, 10),
+@@ -71,7 +71,6 @@ log_element g_log_elements[] = {
+ FILL_LOG_ELEMENT(LOG_ID_DATA, LIGHT_BASE_DATA_SET, 0, 25),
+ FILL_LOG_ELEMENT(LOG_ID_DATA, LIGHT_LUX_DATA_SET, 0, 25),
+ FILL_LOG_ELEMENT(LOG_ID_DATA, CONTEXT_BASE_DATA_SET, 0, 25),
+- FILL_LOG_ELEMENT(LOG_ID_DATA, AUTO_ROTATION_BASE_DATA_SET, 0, 25),
+ FILL_LOG_ELEMENT(LOG_ID_DATA, GRAVITY_BASE_DATA_SET, 0, 25),
+ FILL_LOG_ELEMENT(LOG_ID_DATA, LINEAR_ACCEL_BASE_DATA_SET, 0, 25),
+ FILL_LOG_ELEMENT(LOG_ID_DATA, ORIENTATION_BASE_DATA_SET, 0, 25),
+@@ -180,7 +179,7 @@ bool is_single_state_event(unsigned int event_type)
+ case GEOMAGNETIC_EVENT_CALIBRATION_NEEDED:
+ case LIGHT_EVENT_CHANGE_LEVEL:
+ case PROXIMITY_EVENT_CHANGE_STATE:
+- case AUTO_ROTATION_EVENT_CHANGE_STATE:
++ case AUTO_ROTATION_CHANGE_STATE_EVENT:
+ return true;
+ break;
+ }
+diff --git a/src/libsensord/sensor_auto_rotation.h b/src/libsensord/sensor_auto_rotation.h
+index 752f13d..1f717c5 100755
+--- a/src/libsensord/sensor_auto_rotation.h
++++ b/src/libsensord/sensor_auto_rotation.h
+@@ -36,12 +36,8 @@ extern "C"
+ * @{
+ */
+
+-enum auto_rotation_data_id {
+- AUTO_ROTATION_BASE_DATA_SET = (AUTO_ROTATION_SENSOR << 16) | 0x0001,
+-};
+-
+ enum auto_rotation_event_type {
+- AUTO_ROTATION_EVENT_CHANGE_STATE = (AUTO_ROTATION_SENSOR << 16) | 0x0001,
++ AUTO_ROTATION_CHANGE_STATE_EVENT = (AUTO_ROTATION_SENSOR << 16) | 0x0001,
+ };
+
+ enum auto_rotation_state {
+diff --git a/src/libsensord/sensor_deprecated.h b/src/libsensord/sensor_deprecated.h
+index 7237789..da7fd94 100644
+--- a/src/libsensord/sensor_deprecated.h
++++ b/src/libsensord/sensor_deprecated.h
+@@ -64,6 +64,9 @@ extern "C"
+ #define GEOMAGNETIC_EVENT_CALIBRATION_NEEDED GEOMAGNETIC_CALIBRATION_NEEDED_EVENT
+ #define GEOMAGNETIC_EVENT_UNPROCESSED_DATA_REPORT_ON_TIME GEOMAGNETIC_UNPROCESSED_DATA_EVENT
+
++#define AUTO_ROTATION_BASE_DATA_SET AUTO_ROTATION_CHANGE_STATE_EVENT
++#define AUTO_ROTATION_EVENT_CHANGE_STATE AUTO_ROTATION_CHANGE_STATE_EVENT
++
+ enum accelerometer_rotate_state {
+ ROTATION_UNKNOWN = 0,
+ ROTATION_LANDSCAPE_LEFT = 1,
+--
+2.1.4
+
diff --git a/meta-application-manager/recipes-others/sensord/sensord-extraconf.inc b/meta-application-manager/recipes-others/sensord/sensord-extraconf.inc
new file mode 100644
index 0000000..b5e10a1
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/sensord-extraconf.inc
@@ -0,0 +1,5 @@
+INSANE_SKIP_${PN} = "dev-so"
+SRC_URI += "file://0001-remove-linkerflags.patch"
+SRC_URI += "file://0002-Fix-libinstalldir.patch"
+SRC_URI += "file://0003-remove_checking_libsystemd-daemon.patch"
+SRC_URI += "file://0004-Removing-redundant-auto_rotation-events.patch"
diff --git a/meta-application-manager/recipes-others/sensord/sensord.inc b/meta-application-manager/recipes-others/sensord/sensord.inc
new file mode 100644
index 0000000..34f9f60
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/sensord.inc
@@ -0,0 +1,189 @@
+DESCRIPTION = "Sensor daemon"
+HOMEPAGE = "http://nohomepage.org"
+SECTION = "System/Sensor Framework"
+LICENSE = "Apache-2.0"
+PV = "1.0.0"
+
+SRC_URI = ""
+
+S = "${WORKDIR}/git"
+
+#inherit manifest autotools-brokensep
+inherit autotools-brokensep
+
+BBCLASSEXTEND = ""
+PROVIDES = ""
+
+#PROVIDES by libsensord-dev
+PROVIDES += "libsensord-dev"
+
+
+#PROVIDES by sensord-sensord
+PROVIDES += "sensord-sensord"
+
+
+#PROVIDES by sensord
+
+
+#PROVIDES by libsensord
+PROVIDES += "libsensord"
+PROVIDES += "sensor"
+
+
+RDEPENDS = ""
+#RDEPENDS of libsensord-dev (lib${PN}-dev)
+RDEPENDS_lib${PN}-dev += "sensord"
+
+#RDEPENDS of sensord-sensord (${PN}-${PN})
+RDEPENDS_${PN}-${PN} += "sensord"
+
+#RDEPENDS of libsensord (lib${PN})
+RDEPENDS_lib${PN} += "sensord"
+
+
+DEPENDS = ""
+#DEPENDS of sensord
+DEPENDS += "systemd"
+inherit tizen_cmake
+DEPENDS += "attr"
+DEPENDS += "capi-system-info"
+DEPENDS += "libxml2"
+inherit pkgconfig
+DEPENDS += "dlog"
+DEPENDS += "glib-2.0"
+DEPENDS += "vconf"
+
+do_prep() {
+ cd ${S}
+ chmod -Rf a+rX,u+w,g-w,o-w ${S}
+ #setup -q
+
+}
+
+do_configure() {
+ cd ${S}
+ cp ${S}/packaging/sensord.manifest .
+ cp ${S}/packaging/libsensord.manifest .
+
+ cmake . -DCMAKE_INSTALL_PREFIX=${prefix} -DACCEL=ON \
+ -DGYRO=ON -DPROXI=ON -DLIGHT=ON \
+ -DGEO=ON -DPRESSURE=ON -DTEMPERATURE=ON \
+ -DORIENTATION=ON -DGRAVITY=ON \
+ -DLINEAR_ACCEL=ON -DRV=ON \
+ -DTEST_SUITE=OFF \
+ -DLIBDIR=${prefix}/lib -DINCLUDEDIR=${prefix}/include
+}
+
+do_compile() {
+ cd ${S}
+ LANG=C
+ export LANG
+ unset DISPLAY
+ LD_AS_NEEDED=1; export LD_AS_NEEDED ;
+
+ oe_runmake
+
+
+
+}
+
+do_install() {
+ export RPM_BUILD_ROOT=${D}
+ cd ${S}
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf ${D}
+ mkdir -p ${D}
+
+ rm -rf ${D}
+
+ oe_runmake \
+ DESTDIR=${D} \
+ INSTALL_ROOT=${D} \
+ BINDIR=${prefix}/bin \
+ LIBDIR=${prefix}/lib \
+ install
+ rm -f ${D}${infodir}/dir
+ find ${D} -regex ".*\.la$" | xargs rm -f --
+ find ${D} -regex ".*\.a$" | xargs rm -f --
+
+
+ mkdir -p ${D}/${systemd_unitdir}/system/multi-user.target.wants
+ ln -s ../sensord.service ${D}/${systemd_unitdir}/system/multi-user.target.wants/sensord.service
+
+ mkdir -p ${D}/${systemd_unitdir}/system/sockets.target.wants
+ ln -s ../sensord.socket ${D}/${systemd_unitdir}/system/sockets.target.wants/sensord.socket
+
+
+}
+
+pkg_postinst_libsensord() {
+ #!/bin/sh -e
+
+ [ "x$D" == "x" ] && ldconfig
+}
+
+pkg_postinst_${PN}() {
+ #!/bin/sh -e
+
+ systemctl daemon-reload
+
+}
+
+pkg_postrm_libsensord() {
+ #!/bin/sh -e
+
+ [ "x$D" == "x" ] && ldconfig
+}
+
+pkg_postrm_${PN}() {
+ #!/bin/sh -e
+
+ systemctl daemon-reload
+
+}
+
+PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-locale"
+PACKAGES += " libsensord-dev "
+PACKAGES += " sensord "
+PACKAGES += " libsensord "
+
+libsensord-dev_files = ""
+libsensord-dev_files += "${prefix}/include/sensor/*.h"
+libsensord-dev_files += "${prefix}/include/sf_common/*.h"
+libsensord-dev_files += "${prefix}/lib/libsensor.so"
+libsensord-dev_files += "${prefix}/lib/pkgconfig/sensor.pc"
+libsensord-dev_files += "${prefix}/lib/pkgconfig/sf_common.pc"
+libsensord-dev_files += "${prefix}/lib/pkgconfig/sensord-server.pc"
+
+sensord_files = ""
+sensord_files += "/usr/etc/sensor_plugins.xml"
+sensord_files += "/usr/etc/sensors.xml"
+sensord_files += "/usr/etc/virtual_sensors.xml"
+sensord_files += "${prefix}/bin/sensord"
+sensord_files += "${systemd_unitdir}/system/sensord.service"
+sensord_files += "${systemd_unitdir}/system/sensord.socket"
+sensord_files += "${prefix}/lib/systemd/system/sensord.service"
+sensord_files += "${prefix}/lib/systemd/system/sensord.socket"
+sensord_files += "${systemd_unitdir}/system/multi-user.target.wants/sensord.service"
+sensord_files += "${systemd_unitdir}/system/sockets.target.wants/sensord.socket"
+MANIFESTFILES_${PN} = "sensord.manifest"
+
+libsensord_files = ""
+libsensord_files += "${prefix}/lib/libsensor.so.*"
+libsensord_files += "${prefix}/lib/sensord/*.so*"
+libsensord_files += "${prefix}/lib/libsensord-share.so"
+libsensord_files += "${prefix}/lib/libsensord-server.so"
+MANIFESTFILES_lib${PN} = "libsensord.manifest"
+
+FILES_lib${PN}-dev = "${libsensord-dev_files}"
+FILES_${PN} = "${sensord_files}"
+FILES_lib${PN} = "${libsensord_files}"
+
+PKG_libsensord-dev= "libsensord-dev"
+PKG_sensord= "sensord"
+PKG_libsensord= "libsensord"
+
+require sensord-extraconf.inc
+
diff --git a/meta-application-manager/recipes-others/sensord/sensord_git.bb b/meta-application-manager/recipes-others/sensord/sensord_git.bb
new file mode 100644
index 0000000..f8cc94b
--- /dev/null
+++ b/meta-application-manager/recipes-others/sensord/sensord_git.bb
@@ -0,0 +1,10 @@
+require sensord.inc
+
+PRIORITY = "10"
+
+LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI += "git://review.tizen.org/platform/core/system/sensord;tag=33a40709f3c14b366204925f0bddd2b87c73bb70;nobranch=1"
+
+BBCLASSEXTEND += " native "
+