summaryrefslogtreecommitdiffstats
path: root/external/meta-sdl/recipes-automotive/sdl-core/sdl-core
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-sdl/recipes-automotive/sdl-core/sdl-core')
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch53
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch32
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch32
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch93
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch36
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch59
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch27
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch35
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch119
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch26
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service14
11 files changed, 0 insertions, 526 deletions
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
deleted file mode 100644
index 0038ea00..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From acc1b869e52e1c2e7dba0b534bca34a1e7da8404 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Tue, 19 Jul 2016 07:16:24 +0700
-Subject: [PATCH 01/10] add the default cmake cxx flag for oe
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0001-add-the-default-cmake-cxx-flag-for-oe.patch
----
- CMakeLists.txt | 6 +++---
- src/components/functional_module/CMakeLists.txt | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 450a919..f1dc97a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -75,8 +75,8 @@ set(POLICY_OPTION "$ENV{POLICY_TYPE}")
- set(SECURITY_OPTION "$ENV{SECURITY_MODE}")
- set(COMPONENTS_DIR ${CMAKE_SOURCE_DIR}/src/components)
- set(SNAPSHOT_TAG "$ENV{SNAPSHOT_TAG}")
--set(CMAKE_CXX_COMPILER $ENV{CMAKE_CXX_COMPILER})
--set(CMAKE_C_COMPILER $ENV{CMAKE_C_COMPILER})
-+#set(CMAKE_CXX_COMPILER $ENV{CMAKE_CXX_COMPILER})
-+#set(CMAKE_C_COMPILER $ENV{CMAKE_C_COMPILER})
- set(BUILDDIR "$ENV{BUILDDIR}")
-
- if (ARCH_TYPE_OPTION)
-@@ -192,7 +192,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
- set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
- set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
-
--set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
-
- if (USE_GOLD_LD)
- execute_process(COMMAND ld -v OUTPUT_VARIABLE result)
-diff --git a/src/components/functional_module/CMakeLists.txt b/src/components/functional_module/CMakeLists.txt
-index 07db91f..f5b89e0 100644
---- a/src/components/functional_module/CMakeLists.txt
-+++ b/src/components/functional_module/CMakeLists.txt
-@@ -4,7 +4,7 @@ else()
- set(GCOV_FLAGS "")
- endif()
-
--set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wno-deprecated-declarations -Wall -Werror ${GCOV_FLAGS}")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wno-deprecated-declarations -Wall -Werror ${GCOV_FLAGS}")
-
- if (CMAKE_BUILD_TYPE)
- if (${CMAKE_BUILD_TYPE} STREQUAL "Release")
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
deleted file mode 100644
index 6384ae1c..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 91d7636467b6bb73ed843c16c35da63455872446 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 17 Jul 2016 08:41:03 +0700
-Subject: [PATCH 02/10] Use the default install prefix of cmake
-
-It's better to use the oe cmake install prefix instead of
-the current value. This is for avoiding the wrong
-installation path while do_install().
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0002-Use-the-default-install-prefix-of-cmake.patch
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f1dc97a..732b601 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -189,7 +189,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
-
- # Please do not change compiler/linker flags if You do not know how particular
- # flag is handled by CMake
--set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
-+# set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
- set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
-
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch
deleted file mode 100644
index b35ff2f4..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From ee30bad65787f1e86f9cb83538ef2b85f2125de5 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 17 Jul 2016 12:25:52 +0700
-Subject: [PATCH 03/10] disable building sdl tools
-
-There is an issue of do_install(). The tools are shipped
-to the wrong location.BTW There may not use of intergen now.
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0003-disable-building-sdl-tools.patch
----
- CMakeLists.txt | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 732b601..55cd32e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -408,7 +408,8 @@ endif()
- add_subdirectory(./src/3rd_party-static)
-
- # --- Tools
--add_subdirectory(./tools)
-+# inactive building tools now
-+#add_subdirectory(./tools)
-
- # --- Components
- add_subdirectory(./src/components)
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch
deleted file mode 100644
index 0ec53702..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 855e1548269d830b07962a72fa17100193de35f3 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 17 Jul 2016 14:03:13 +0700
-Subject: [PATCH 04/10] Change to use standard libdir
-
-The lib*.so should be in /usr/lib path.
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0004-Change-to-use-standard-libdir.patch
----
- src/components/policy/policy_external/CMakeLists.txt | 4 ++--
- src/components/policy/policy_regular/CMakeLists.txt | 2 +-
- src/components/remote_control/CMakeLists.txt | 2 +-
- src/components/utils/CMakeLists.txt | 2 +-
- src/plugins/appenders/CMakeLists.txt | 2 +-
- 5 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/components/policy/policy_external/CMakeLists.txt b/src/components/policy/policy_external/CMakeLists.txt
-index 8d04f20..7a421be 100644
---- a/src/components/policy/policy_external/CMakeLists.txt
-+++ b/src/components/policy/policy_external/CMakeLists.txt
-@@ -30,7 +30,7 @@
-
- # --- Policy
- set(target Policy)
--set(install_destination bin)
-+set(install_destination ${CMAKE_INSTALL_LIBDIR})
- set(copy_destination ${CMAKE_BINARY_DIR}/src/appMain)
- set(library_name ${CMAKE_SHARED_LIBRARY_PREFIX}${target}${CMAKE_SHARED_LIBRARY_SUFFIX})
-
-@@ -92,7 +92,7 @@ add_custom_target(copy_library_${target} ALL
- COMMENT "Copying library ${library_name}")
-
- install(TARGETS ${target}
-- DESTINATION ${install_destination}
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE
- GROUP_READ GROUP_EXECUTE
- WORLD_READ WORLD_EXECUTE
-diff --git a/src/components/policy/policy_regular/CMakeLists.txt b/src/components/policy/policy_regular/CMakeLists.txt
-index c7b9c06..61ddecb 100644
---- a/src/components/policy/policy_regular/CMakeLists.txt
-+++ b/src/components/policy/policy_regular/CMakeLists.txt
-@@ -102,7 +102,7 @@ endif()
-
- set(LIBRARY_NAME ${CMAKE_SHARED_LIBRARY_PREFIX}Policy${CMAKE_SHARED_LIBRARY_SUFFIX})
- set(TARGET_LOCATION ${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME})
--set(INSTALL_DESTINATION bin)
-+set(INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR})
- set(COPY_DESTINATION ${CMAKE_BINARY_DIR}/src/appMain)
-
- add_custom_target(copy_policy_library ALL
-diff --git a/src/components/remote_control/CMakeLists.txt b/src/components/remote_control/CMakeLists.txt
-index a320273..c1d2c51 100644
---- a/src/components/remote_control/CMakeLists.txt
-+++ b/src/components/remote_control/CMakeLists.txt
-@@ -1,5 +1,5 @@
- set(target "RemoteControlModule")
--set(install_destination ${CMAKE_BINARY_DIR}/bin/plugins)
-+set(install_destination ${CMAKE_INSTALL_LIBDIR})
- if (ENABLE_GCOV)
- set(GCOV_FLAGS "-ftest-coverage -fprofile-arcs")
- else()
-diff --git a/src/components/utils/CMakeLists.txt b/src/components/utils/CMakeLists.txt
-index 51835c1..abb4cd7 100644
---- a/src/components/utils/CMakeLists.txt
-+++ b/src/components/utils/CMakeLists.txt
-@@ -124,7 +124,7 @@ if(BUILD_TESTS)
- endif()
-
- install(TARGETS "Utils"
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS
- OWNER_READ OWNER_WRITE
- GROUP_READ
-diff --git a/src/plugins/appenders/CMakeLists.txt b/src/plugins/appenders/CMakeLists.txt
-index 3d18e62..4c39f8b 100644
---- a/src/plugins/appenders/CMakeLists.txt
-+++ b/src/plugins/appenders/CMakeLists.txt
-@@ -46,7 +46,7 @@ target_link_libraries(appenders ${LIBRARIES})
- add_dependencies(appenders install-3rd_party_logger)
-
- install(TARGETS appenders
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS
- OWNER_READ OWNER_WRITE OWNER_EXECUTE
- GROUP_READ GROUP_EXECUTE
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch
deleted file mode 100644
index 75d43906..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 570405af8e5c874db1852bdfb333ec0c941093ac Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 12 Feb 2017 16:54:48 +0700
-Subject: [PATCH 05/10] add env for log4cxx properties path
-
-Add the env variable SDL_LOG4CXX_PROPERTIES_FILE
-to indicate the path of log4cxx configure file.
-
-%% original patch: 0005-add-env-for-log4cxx-properties-path.patch
----
- src/appMain/main.cc | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/src/appMain/main.cc b/src/appMain/main.cc
-index feb5b58..08e65f7 100644
---- a/src/appMain/main.cc
-+++ b/src/appMain/main.cc
-@@ -112,8 +112,13 @@ int32_t main(int32_t argc, char** argv) {
-
- // --------------------------------------------------------------------------
- // Logger initialization
-- INIT_LOGGER("log4cxx.properties", profile_instance.logs_enabled());
--
-+ const char* log4cxx_path = getenv("SDL_LOG4CXX_PROPERTIES_FILE");
-+ if (!log4cxx_path) {
-+ INIT_LOGGER("log4cxx.properties", profile_instance.logs_enabled());
-+ } else {
-+ std::string log4cxx_properties = std::string(log4cxx_path);
-+ INIT_LOGGER(log4cxx_properties, profile_instance.logs_enabled());
-+ }
- threads::Thread::SetNameForId(threads::Thread::CurrentId(), "MainThread");
-
- if (!utils::appenders_loader.Loaded()) {
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch
deleted file mode 100644
index 0dd00ebf..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From ca30ea45d91b9ec15ea456ce4492575bee571c56 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Tue, 19 Dec 2017 23:43:56 +0700
-Subject: [PATCH 06/10] Install the configure file to sysconf dir
-
-Use CMAKE_INSTALL_SYSCONFDIR for sdl configure files.
-
-%% original patch: 0006-Install-the-configure-file-to-sysconf-dir.patch
----
- src/appMain/CMakeLists.txt | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/src/appMain/CMakeLists.txt b/src/appMain/CMakeLists.txt
-index 5148676..f6d8093 100644
---- a/src/appMain/CMakeLists.txt
-+++ b/src/appMain/CMakeLists.txt
-@@ -155,15 +155,15 @@ target_link_libraries(${PROJECT} ${LIBRARIES})
-
- add_dependencies(${PROJECT} Policy)
-
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/log4cxx.properties DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/audio.8bit.wav DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/test.txt DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/smartDeviceLink.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/hmi_capabilities.json DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/sdl_preloaded_pt.json DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/sample_policy_manager.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/start.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/start_external_proprietary.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/log4cxx.properties DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/audio.8bit.wav DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/test.txt DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/smartDeviceLink.ini DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/hmi_capabilities.json DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/sdl_preloaded_pt.json DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/sample_policy_manager.py DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/start.sh DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/start_external_proprietary.sh DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
- if (CMAKE_SYSTEM_NAME STREQUAL "QNX")
- file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/init_policy.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
- endif ()
-@@ -215,12 +215,12 @@ install(
- FILES log4cxx.properties audio.8bit.wav test.txt smartDeviceLink.ini
- hmi_capabilities.json sdl_preloaded_pt.json sample_policy_manager.py
- ${CMAKE_SOURCE_DIR}/mycert.pem ${CMAKE_SOURCE_DIR}/mykey.pem
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink
- )
-
- install(
- FILES sdl_preloaded_pt.json
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink
- )
-
- if (${QT_HMI})
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch
deleted file mode 100644
index 38de64a6..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From e25165f41748b2f05b2a28f4a64682ac71801c33 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Thu, 21 Dec 2017 23:49:53 +0700
-Subject: [PATCH 07/10] Add standard /usr/lib path to rpath
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0007-Add-standard-usr-lib-path-to-rpath.patch
----
- CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 55cd32e..e207923 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -383,6 +383,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "QNX")
- endif()
-
- SET(RPATH_DIRECTORIES
-+ ${CMAKE_INSTALL_LIBDIR}
- ${CMAKE_INSTALL_PREFIX}/bin/plugins
- /usr/local/lib
- /usr/local
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch
deleted file mode 100644
index 12267d60..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 626676fab6a98041d1da32872df0fe79103705da Mon Sep 17 00:00:00 2001
-From: Matt Hoosier <matt.hoosier@garmin.com>
-Date: Wed, 18 Apr 2018 11:48:30 -0500
-Subject: [PATCH 08/10] Unbreak build when BUILD_BT_SUPPORT=OFF
-
-Fixes a logic error in computing source-exclusion lists.
-
-%% original patch: 0001-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch
----
- src/components/transport_manager/CMakeLists.txt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/components/transport_manager/CMakeLists.txt b/src/components/transport_manager/CMakeLists.txt
-index 4fa2243..c31cb2b 100644
---- a/src/components/transport_manager/CMakeLists.txt
-+++ b/src/components/transport_manager/CMakeLists.txt
-@@ -68,13 +68,13 @@ endif()
-
- if(BUILD_USB_SUPPORT)
- if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
-- set(EXCLUDE_PATHS
-+ list(APPEND EXCLUDE_PATHS
- ${COMPONENTS_DIR}/transport_manager/include/transport_manager/usb/qnx
- ${COMPONENTS_DIR}/transport_manager/src/usb/qnx
- )
-
- elseif(CMAKE_SYSTEM_NAME STREQUAL "QNX")
-- set(EXCLUDE_PATHS
-+ list(APPEND EXCLUDE_PATHS
- ${COMPONENTS_DIR}/transport_manager/include/transport_manager/usb/libusb
- ${COMPONENTS_DIR}/transport_manager/src/usb/libusb
- )
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch
deleted file mode 100644
index 1876fe1a..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-From ca7f596bf905f491f4984ae9afc98da055eaa08f Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sat, 9 Jun 2018 23:09:28 +0700
-Subject: [PATCH 09/10] Function GetDataOnSessionKey cannot be overloade
-
-Temp solution for
-https://github.com/smartdevicelink/sdl_core/issues/2137
-comment of @shoamano83
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
----
- .../include/connection_handler/connection_handler_impl.h | 14 --------------
- .../connection_handler/src/connection_handler_impl.cc | 12 ------------
- .../include/connection_handler/connection_handler.h | 15 ---------------
- .../include/protocol_handler/session_observer.h | 14 --------------
- 4 files changed, 55 deletions(-)
-
-diff --git a/src/components/connection_handler/include/connection_handler/connection_handler_impl.h b/src/components/connection_handler/include/connection_handler/connection_handler_impl.h
-index 66b2d7c..e270d9f 100644
---- a/src/components/connection_handler/include/connection_handler/connection_handler_impl.h
-+++ b/src/components/connection_handler/include/connection_handler/connection_handler_impl.h
-@@ -503,20 +503,6 @@ class ConnectionHandlerImpl
- std::list<int32_t>* sessions_list,
- connection_handler::DeviceHandle* device_id) const OVERRIDE;
-
-- /**
-- * DEPRECATED
-- * \brief information about given Connection Key.
-- * \param key Unique key used by other components as session identifier
-- * \param app_id Returned: ApplicationID
-- * \param sessions_list Returned: List of session keys
-- * \param device_id Returned: DeviceID
-- * \return int32_t -1 in case of error or 0 in case of success
-- */
-- int32_t GetDataOnSessionKey(uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const OVERRIDE;
--
- const ConnectionHandlerSettings& get_settings() const OVERRIDE;
-
- const protocol_handler::SessionObserver& get_session_observer();
-diff --git a/src/components/connection_handler/src/connection_handler_impl.cc b/src/components/connection_handler/src/connection_handler_impl.cc
-index 5b26304..a9809c5 100644
---- a/src/components/connection_handler/src/connection_handler_impl.cc
-+++ b/src/components/connection_handler/src/connection_handler_impl.cc
-@@ -716,18 +716,6 @@ int32_t ConnectionHandlerImpl::GetDataOnSessionKey(
- return 0;
- }
-
--int32_t ConnectionHandlerImpl::GetDataOnSessionKey(
-- uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const {
-- LOG4CXX_AUTO_TRACE(logger_);
-- DeviceHandle handle;
-- int32_t result = GetDataOnSessionKey(key, app_id, sessions_list, &handle);
-- *device_id = static_cast<uint32_t>(handle);
-- return result;
--}
--
- const ConnectionHandlerSettings& ConnectionHandlerImpl::get_settings() const {
- return settings_;
- }
-diff --git a/src/components/include/connection_handler/connection_handler.h b/src/components/include/connection_handler/connection_handler.h
-index 1fcf5e4..352f886 100644
---- a/src/components/include/connection_handler/connection_handler.h
-+++ b/src/components/include/connection_handler/connection_handler.h
-@@ -183,21 +183,6 @@ class ConnectionHandler {
- connection_handler::DeviceHandle* device_id) const = 0;
-
- /**
-- * DEPRECATED
-- * \brief information about given Connection Key.
-- * \param key Unique key used by other components as session identifier
-- * \param app_id Returned: ApplicationID
-- * \param sessions_list Returned: List of session keys
-- * \param device_id Returned: DeviceID
-- * \return int32_t -1 in case of error or 0 in case of success
-- */
-- DEPRECATED virtual int32_t GetDataOnSessionKey(
-- uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const = 0;
--
-- /**
- * @brief GetConnectedDevicesMAC allows to obtain MAC adresses for all
- * currently connected devices.
- *
-diff --git a/src/components/include/protocol_handler/session_observer.h b/src/components/include/protocol_handler/session_observer.h
-index 3482c65..7e87b6f 100644
---- a/src/components/include/protocol_handler/session_observer.h
-+++ b/src/components/include/protocol_handler/session_observer.h
-@@ -231,20 +231,6 @@ class SessionObserver {
- uint8_t* sessionId) const = 0;
-
- /**
-- * DEPRECATED
-- * \brief information about given Connection Key.
-- * \param key Unique key used by other components as session identifier
-- * \param app_id Returned: ApplicationID
-- * \param sessions_list Returned: List of session keys
-- * \param device_id Returned: DeviceID
-- * \return int32_t -1 in case of error or 0 in case of success
-- */
-- virtual int32_t GetDataOnSessionKey(uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const = 0;
--
-- /**
- * \brief information about given Connection Key.
- * \param key Unique key used by other components as session identifier
- * \param app_id Returned: ApplicationID
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch
deleted file mode 100644
index fbae8340..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 085f26f304a0065ddeeb87b4b3ee977029c609b8 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sat, 9 Jun 2018 23:29:26 +0700
-Subject: [PATCH 10/10] fix error of WriteHandshakeData return value
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
----
- src/components/security_manager/src/ssl_context_impl.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/components/security_manager/src/ssl_context_impl.cc b/src/components/security_manager/src/ssl_context_impl.cc
-index 5be5ff8..0b30198 100644
---- a/src/components/security_manager/src/ssl_context_impl.cc
-+++ b/src/components/security_manager/src/ssl_context_impl.cc
-@@ -280,7 +280,7 @@ bool CryptoManagerImpl::SSLContextImpl::WriteHandshakeData(
- if (ret <= 0) {
- is_handshake_pending_ = false;
- ResetConnection();
-- return Handshake_Result_AbnormalFail;
-+ return false;
- }
- }
- return true;
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service
deleted file mode 100644
index 40b308a4..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Smart Device Link Core
-After=bluetooth.service
-Requires=bluetooth.service
-
-[Service]
-Environment="SDL_LOG4CXX_PROPERTIES_FILE=/etc/smartdevicelink/log4cxx.properties"
-StandardOutput=journal
-StandardError=journal
-ExecStart=/usr/bin/smartDeviceLinkCore /etc/smartdevicelink/smartDeviceLink.ini
-ExecStop=/bin/kill -HUP $MAINPID
-
-[Install]
-WantedBy=multi-user.target