summaryrefslogtreecommitdiffstats
path: root/external/meta-sdl/recipes-automotive
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-sdl/recipes-automotive')
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch53
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch32
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch32
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch93
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch36
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch59
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch27
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch35
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch119
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch26
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service14
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core_4.5.0.bb112
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb34
13 files changed, 0 insertions, 672 deletions
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
deleted file mode 100644
index 0038ea00..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From acc1b869e52e1c2e7dba0b534bca34a1e7da8404 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Tue, 19 Jul 2016 07:16:24 +0700
-Subject: [PATCH 01/10] add the default cmake cxx flag for oe
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0001-add-the-default-cmake-cxx-flag-for-oe.patch
----
- CMakeLists.txt | 6 +++---
- src/components/functional_module/CMakeLists.txt | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 450a919..f1dc97a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -75,8 +75,8 @@ set(POLICY_OPTION "$ENV{POLICY_TYPE}")
- set(SECURITY_OPTION "$ENV{SECURITY_MODE}")
- set(COMPONENTS_DIR ${CMAKE_SOURCE_DIR}/src/components)
- set(SNAPSHOT_TAG "$ENV{SNAPSHOT_TAG}")
--set(CMAKE_CXX_COMPILER $ENV{CMAKE_CXX_COMPILER})
--set(CMAKE_C_COMPILER $ENV{CMAKE_C_COMPILER})
-+#set(CMAKE_CXX_COMPILER $ENV{CMAKE_CXX_COMPILER})
-+#set(CMAKE_C_COMPILER $ENV{CMAKE_C_COMPILER})
- set(BUILDDIR "$ENV{BUILDDIR}")
-
- if (ARCH_TYPE_OPTION)
-@@ -192,7 +192,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
- set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
- set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
-
--set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
-
- if (USE_GOLD_LD)
- execute_process(COMMAND ld -v OUTPUT_VARIABLE result)
-diff --git a/src/components/functional_module/CMakeLists.txt b/src/components/functional_module/CMakeLists.txt
-index 07db91f..f5b89e0 100644
---- a/src/components/functional_module/CMakeLists.txt
-+++ b/src/components/functional_module/CMakeLists.txt
-@@ -4,7 +4,7 @@ else()
- set(GCOV_FLAGS "")
- endif()
-
--set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wno-deprecated-declarations -Wall -Werror ${GCOV_FLAGS}")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wno-deprecated-declarations -Wall -Werror ${GCOV_FLAGS}")
-
- if (CMAKE_BUILD_TYPE)
- if (${CMAKE_BUILD_TYPE} STREQUAL "Release")
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
deleted file mode 100644
index 6384ae1c..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 91d7636467b6bb73ed843c16c35da63455872446 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 17 Jul 2016 08:41:03 +0700
-Subject: [PATCH 02/10] Use the default install prefix of cmake
-
-It's better to use the oe cmake install prefix instead of
-the current value. This is for avoiding the wrong
-installation path while do_install().
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0002-Use-the-default-install-prefix-of-cmake.patch
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f1dc97a..732b601 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -189,7 +189,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
-
- # Please do not change compiler/linker flags if You do not know how particular
- # flag is handled by CMake
--set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
-+# set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
- set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
-
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch
deleted file mode 100644
index b35ff2f4..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0003-disable-building-sdl-tools.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From ee30bad65787f1e86f9cb83538ef2b85f2125de5 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 17 Jul 2016 12:25:52 +0700
-Subject: [PATCH 03/10] disable building sdl tools
-
-There is an issue of do_install(). The tools are shipped
-to the wrong location.BTW There may not use of intergen now.
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0003-disable-building-sdl-tools.patch
----
- CMakeLists.txt | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 732b601..55cd32e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -408,7 +408,8 @@ endif()
- add_subdirectory(./src/3rd_party-static)
-
- # --- Tools
--add_subdirectory(./tools)
-+# inactive building tools now
-+#add_subdirectory(./tools)
-
- # --- Components
- add_subdirectory(./src/components)
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch
deleted file mode 100644
index 0ec53702..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 855e1548269d830b07962a72fa17100193de35f3 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 17 Jul 2016 14:03:13 +0700
-Subject: [PATCH 04/10] Change to use standard libdir
-
-The lib*.so should be in /usr/lib path.
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0004-Change-to-use-standard-libdir.patch
----
- src/components/policy/policy_external/CMakeLists.txt | 4 ++--
- src/components/policy/policy_regular/CMakeLists.txt | 2 +-
- src/components/remote_control/CMakeLists.txt | 2 +-
- src/components/utils/CMakeLists.txt | 2 +-
- src/plugins/appenders/CMakeLists.txt | 2 +-
- 5 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/components/policy/policy_external/CMakeLists.txt b/src/components/policy/policy_external/CMakeLists.txt
-index 8d04f20..7a421be 100644
---- a/src/components/policy/policy_external/CMakeLists.txt
-+++ b/src/components/policy/policy_external/CMakeLists.txt
-@@ -30,7 +30,7 @@
-
- # --- Policy
- set(target Policy)
--set(install_destination bin)
-+set(install_destination ${CMAKE_INSTALL_LIBDIR})
- set(copy_destination ${CMAKE_BINARY_DIR}/src/appMain)
- set(library_name ${CMAKE_SHARED_LIBRARY_PREFIX}${target}${CMAKE_SHARED_LIBRARY_SUFFIX})
-
-@@ -92,7 +92,7 @@ add_custom_target(copy_library_${target} ALL
- COMMENT "Copying library ${library_name}")
-
- install(TARGETS ${target}
-- DESTINATION ${install_destination}
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE
- GROUP_READ GROUP_EXECUTE
- WORLD_READ WORLD_EXECUTE
-diff --git a/src/components/policy/policy_regular/CMakeLists.txt b/src/components/policy/policy_regular/CMakeLists.txt
-index c7b9c06..61ddecb 100644
---- a/src/components/policy/policy_regular/CMakeLists.txt
-+++ b/src/components/policy/policy_regular/CMakeLists.txt
-@@ -102,7 +102,7 @@ endif()
-
- set(LIBRARY_NAME ${CMAKE_SHARED_LIBRARY_PREFIX}Policy${CMAKE_SHARED_LIBRARY_SUFFIX})
- set(TARGET_LOCATION ${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME})
--set(INSTALL_DESTINATION bin)
-+set(INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR})
- set(COPY_DESTINATION ${CMAKE_BINARY_DIR}/src/appMain)
-
- add_custom_target(copy_policy_library ALL
-diff --git a/src/components/remote_control/CMakeLists.txt b/src/components/remote_control/CMakeLists.txt
-index a320273..c1d2c51 100644
---- a/src/components/remote_control/CMakeLists.txt
-+++ b/src/components/remote_control/CMakeLists.txt
-@@ -1,5 +1,5 @@
- set(target "RemoteControlModule")
--set(install_destination ${CMAKE_BINARY_DIR}/bin/plugins)
-+set(install_destination ${CMAKE_INSTALL_LIBDIR})
- if (ENABLE_GCOV)
- set(GCOV_FLAGS "-ftest-coverage -fprofile-arcs")
- else()
-diff --git a/src/components/utils/CMakeLists.txt b/src/components/utils/CMakeLists.txt
-index 51835c1..abb4cd7 100644
---- a/src/components/utils/CMakeLists.txt
-+++ b/src/components/utils/CMakeLists.txt
-@@ -124,7 +124,7 @@ if(BUILD_TESTS)
- endif()
-
- install(TARGETS "Utils"
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS
- OWNER_READ OWNER_WRITE
- GROUP_READ
-diff --git a/src/plugins/appenders/CMakeLists.txt b/src/plugins/appenders/CMakeLists.txt
-index 3d18e62..4c39f8b 100644
---- a/src/plugins/appenders/CMakeLists.txt
-+++ b/src/plugins/appenders/CMakeLists.txt
-@@ -46,7 +46,7 @@ target_link_libraries(appenders ${LIBRARIES})
- add_dependencies(appenders install-3rd_party_logger)
-
- install(TARGETS appenders
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS
- OWNER_READ OWNER_WRITE OWNER_EXECUTE
- GROUP_READ GROUP_EXECUTE
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch
deleted file mode 100644
index 75d43906..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0005-add-env-for-log4cxx-properties-path.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 570405af8e5c874db1852bdfb333ec0c941093ac Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 12 Feb 2017 16:54:48 +0700
-Subject: [PATCH 05/10] add env for log4cxx properties path
-
-Add the env variable SDL_LOG4CXX_PROPERTIES_FILE
-to indicate the path of log4cxx configure file.
-
-%% original patch: 0005-add-env-for-log4cxx-properties-path.patch
----
- src/appMain/main.cc | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/src/appMain/main.cc b/src/appMain/main.cc
-index feb5b58..08e65f7 100644
---- a/src/appMain/main.cc
-+++ b/src/appMain/main.cc
-@@ -112,8 +112,13 @@ int32_t main(int32_t argc, char** argv) {
-
- // --------------------------------------------------------------------------
- // Logger initialization
-- INIT_LOGGER("log4cxx.properties", profile_instance.logs_enabled());
--
-+ const char* log4cxx_path = getenv("SDL_LOG4CXX_PROPERTIES_FILE");
-+ if (!log4cxx_path) {
-+ INIT_LOGGER("log4cxx.properties", profile_instance.logs_enabled());
-+ } else {
-+ std::string log4cxx_properties = std::string(log4cxx_path);
-+ INIT_LOGGER(log4cxx_properties, profile_instance.logs_enabled());
-+ }
- threads::Thread::SetNameForId(threads::Thread::CurrentId(), "MainThread");
-
- if (!utils::appenders_loader.Loaded()) {
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch
deleted file mode 100644
index 0dd00ebf..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From ca30ea45d91b9ec15ea456ce4492575bee571c56 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Tue, 19 Dec 2017 23:43:56 +0700
-Subject: [PATCH 06/10] Install the configure file to sysconf dir
-
-Use CMAKE_INSTALL_SYSCONFDIR for sdl configure files.
-
-%% original patch: 0006-Install-the-configure-file-to-sysconf-dir.patch
----
- src/appMain/CMakeLists.txt | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/src/appMain/CMakeLists.txt b/src/appMain/CMakeLists.txt
-index 5148676..f6d8093 100644
---- a/src/appMain/CMakeLists.txt
-+++ b/src/appMain/CMakeLists.txt
-@@ -155,15 +155,15 @@ target_link_libraries(${PROJECT} ${LIBRARIES})
-
- add_dependencies(${PROJECT} Policy)
-
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/log4cxx.properties DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/audio.8bit.wav DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/test.txt DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/smartDeviceLink.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/hmi_capabilities.json DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/sdl_preloaded_pt.json DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/sample_policy_manager.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/start.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/start_external_proprietary.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/log4cxx.properties DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/audio.8bit.wav DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/test.txt DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/smartDeviceLink.ini DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/hmi_capabilities.json DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/sdl_preloaded_pt.json DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/sample_policy_manager.py DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/start.sh DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/start_external_proprietary.sh DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
- if (CMAKE_SYSTEM_NAME STREQUAL "QNX")
- file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/init_policy.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
- endif ()
-@@ -215,12 +215,12 @@ install(
- FILES log4cxx.properties audio.8bit.wav test.txt smartDeviceLink.ini
- hmi_capabilities.json sdl_preloaded_pt.json sample_policy_manager.py
- ${CMAKE_SOURCE_DIR}/mycert.pem ${CMAKE_SOURCE_DIR}/mykey.pem
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink
- )
-
- install(
- FILES sdl_preloaded_pt.json
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink
- )
-
- if (${QT_HMI})
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch
deleted file mode 100644
index 38de64a6..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0007-Add-standard-usr-lib-path-to-rpath.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From e25165f41748b2f05b2a28f4a64682ac71801c33 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Thu, 21 Dec 2017 23:49:53 +0700
-Subject: [PATCH 07/10] Add standard /usr/lib path to rpath
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0007-Add-standard-usr-lib-path-to-rpath.patch
----
- CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 55cd32e..e207923 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -383,6 +383,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "QNX")
- endif()
-
- SET(RPATH_DIRECTORIES
-+ ${CMAKE_INSTALL_LIBDIR}
- ${CMAKE_INSTALL_PREFIX}/bin/plugins
- /usr/local/lib
- /usr/local
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch
deleted file mode 100644
index 12267d60..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 626676fab6a98041d1da32872df0fe79103705da Mon Sep 17 00:00:00 2001
-From: Matt Hoosier <matt.hoosier@garmin.com>
-Date: Wed, 18 Apr 2018 11:48:30 -0500
-Subject: [PATCH 08/10] Unbreak build when BUILD_BT_SUPPORT=OFF
-
-Fixes a logic error in computing source-exclusion lists.
-
-%% original patch: 0001-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch
----
- src/components/transport_manager/CMakeLists.txt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/components/transport_manager/CMakeLists.txt b/src/components/transport_manager/CMakeLists.txt
-index 4fa2243..c31cb2b 100644
---- a/src/components/transport_manager/CMakeLists.txt
-+++ b/src/components/transport_manager/CMakeLists.txt
-@@ -68,13 +68,13 @@ endif()
-
- if(BUILD_USB_SUPPORT)
- if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
-- set(EXCLUDE_PATHS
-+ list(APPEND EXCLUDE_PATHS
- ${COMPONENTS_DIR}/transport_manager/include/transport_manager/usb/qnx
- ${COMPONENTS_DIR}/transport_manager/src/usb/qnx
- )
-
- elseif(CMAKE_SYSTEM_NAME STREQUAL "QNX")
-- set(EXCLUDE_PATHS
-+ list(APPEND EXCLUDE_PATHS
- ${COMPONENTS_DIR}/transport_manager/include/transport_manager/usb/libusb
- ${COMPONENTS_DIR}/transport_manager/src/usb/libusb
- )
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch
deleted file mode 100644
index 1876fe1a..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-From ca7f596bf905f491f4984ae9afc98da055eaa08f Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sat, 9 Jun 2018 23:09:28 +0700
-Subject: [PATCH 09/10] Function GetDataOnSessionKey cannot be overloade
-
-Temp solution for
-https://github.com/smartdevicelink/sdl_core/issues/2137
-comment of @shoamano83
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
----
- .../include/connection_handler/connection_handler_impl.h | 14 --------------
- .../connection_handler/src/connection_handler_impl.cc | 12 ------------
- .../include/connection_handler/connection_handler.h | 15 ---------------
- .../include/protocol_handler/session_observer.h | 14 --------------
- 4 files changed, 55 deletions(-)
-
-diff --git a/src/components/connection_handler/include/connection_handler/connection_handler_impl.h b/src/components/connection_handler/include/connection_handler/connection_handler_impl.h
-index 66b2d7c..e270d9f 100644
---- a/src/components/connection_handler/include/connection_handler/connection_handler_impl.h
-+++ b/src/components/connection_handler/include/connection_handler/connection_handler_impl.h
-@@ -503,20 +503,6 @@ class ConnectionHandlerImpl
- std::list<int32_t>* sessions_list,
- connection_handler::DeviceHandle* device_id) const OVERRIDE;
-
-- /**
-- * DEPRECATED
-- * \brief information about given Connection Key.
-- * \param key Unique key used by other components as session identifier
-- * \param app_id Returned: ApplicationID
-- * \param sessions_list Returned: List of session keys
-- * \param device_id Returned: DeviceID
-- * \return int32_t -1 in case of error or 0 in case of success
-- */
-- int32_t GetDataOnSessionKey(uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const OVERRIDE;
--
- const ConnectionHandlerSettings& get_settings() const OVERRIDE;
-
- const protocol_handler::SessionObserver& get_session_observer();
-diff --git a/src/components/connection_handler/src/connection_handler_impl.cc b/src/components/connection_handler/src/connection_handler_impl.cc
-index 5b26304..a9809c5 100644
---- a/src/components/connection_handler/src/connection_handler_impl.cc
-+++ b/src/components/connection_handler/src/connection_handler_impl.cc
-@@ -716,18 +716,6 @@ int32_t ConnectionHandlerImpl::GetDataOnSessionKey(
- return 0;
- }
-
--int32_t ConnectionHandlerImpl::GetDataOnSessionKey(
-- uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const {
-- LOG4CXX_AUTO_TRACE(logger_);
-- DeviceHandle handle;
-- int32_t result = GetDataOnSessionKey(key, app_id, sessions_list, &handle);
-- *device_id = static_cast<uint32_t>(handle);
-- return result;
--}
--
- const ConnectionHandlerSettings& ConnectionHandlerImpl::get_settings() const {
- return settings_;
- }
-diff --git a/src/components/include/connection_handler/connection_handler.h b/src/components/include/connection_handler/connection_handler.h
-index 1fcf5e4..352f886 100644
---- a/src/components/include/connection_handler/connection_handler.h
-+++ b/src/components/include/connection_handler/connection_handler.h
-@@ -183,21 +183,6 @@ class ConnectionHandler {
- connection_handler::DeviceHandle* device_id) const = 0;
-
- /**
-- * DEPRECATED
-- * \brief information about given Connection Key.
-- * \param key Unique key used by other components as session identifier
-- * \param app_id Returned: ApplicationID
-- * \param sessions_list Returned: List of session keys
-- * \param device_id Returned: DeviceID
-- * \return int32_t -1 in case of error or 0 in case of success
-- */
-- DEPRECATED virtual int32_t GetDataOnSessionKey(
-- uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const = 0;
--
-- /**
- * @brief GetConnectedDevicesMAC allows to obtain MAC adresses for all
- * currently connected devices.
- *
-diff --git a/src/components/include/protocol_handler/session_observer.h b/src/components/include/protocol_handler/session_observer.h
-index 3482c65..7e87b6f 100644
---- a/src/components/include/protocol_handler/session_observer.h
-+++ b/src/components/include/protocol_handler/session_observer.h
-@@ -231,20 +231,6 @@ class SessionObserver {
- uint8_t* sessionId) const = 0;
-
- /**
-- * DEPRECATED
-- * \brief information about given Connection Key.
-- * \param key Unique key used by other components as session identifier
-- * \param app_id Returned: ApplicationID
-- * \param sessions_list Returned: List of session keys
-- * \param device_id Returned: DeviceID
-- * \return int32_t -1 in case of error or 0 in case of success
-- */
-- virtual int32_t GetDataOnSessionKey(uint32_t key,
-- uint32_t* app_id,
-- std::list<int32_t>* sessions_list,
-- uint32_t* device_id) const = 0;
--
-- /**
- * \brief information about given Connection Key.
- * \param key Unique key used by other components as session identifier
- * \param app_id Returned: ApplicationID
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch
deleted file mode 100644
index fbae8340..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0010-fix-error-of-WriteHandshakeData-return-value.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 085f26f304a0065ddeeb87b4b3ee977029c609b8 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sat, 9 Jun 2018 23:29:26 +0700
-Subject: [PATCH 10/10] fix error of WriteHandshakeData return value
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
----
- src/components/security_manager/src/ssl_context_impl.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/components/security_manager/src/ssl_context_impl.cc b/src/components/security_manager/src/ssl_context_impl.cc
-index 5be5ff8..0b30198 100644
---- a/src/components/security_manager/src/ssl_context_impl.cc
-+++ b/src/components/security_manager/src/ssl_context_impl.cc
-@@ -280,7 +280,7 @@ bool CryptoManagerImpl::SSLContextImpl::WriteHandshakeData(
- if (ret <= 0) {
- is_handshake_pending_ = false;
- ResetConnection();
-- return Handshake_Result_AbnormalFail;
-+ return false;
- }
- }
- return true;
---
-2.7.4
-
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service
deleted file mode 100644
index 40b308a4..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/smartdevicelink.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Smart Device Link Core
-After=bluetooth.service
-Requires=bluetooth.service
-
-[Service]
-Environment="SDL_LOG4CXX_PROPERTIES_FILE=/etc/smartdevicelink/log4cxx.properties"
-StandardOutput=journal
-StandardError=journal
-ExecStart=/usr/bin/smartDeviceLinkCore /etc/smartdevicelink/smartDeviceLink.ini
-ExecStop=/bin/kill -HUP $MAINPID
-
-[Install]
-WantedBy=multi-user.target
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core_4.5.0.bb b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core_4.5.0.bb
deleted file mode 100644
index 331e8917..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core_4.5.0.bb
+++ /dev/null
@@ -1,112 +0,0 @@
-SUMMARY = "SmartDeviceLink In-Vehicle Software"
-DESCRIPTION = "SmartDeviceLink (SDL) is a standard set of protocols and messages \
- that connect applications on a smartphone to a vehicle head unit."
-HOMEPAGE = "https://www.smartdevicelink.com"
-LICENSE = "BSD-3-Clause"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ecc58617265863ee517caa91580a143d \
- file://src/3rd_party/expat-2.1.0/COPYING;md5=1b71f681713d1256e1c23b0890920874 \
- file://src/3rd_party/apr-1.5.0/LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
- file://src/3rd_party/apr-util-1.5.3/LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
- file://src/3rd_party/apr-util-1.5.3/xml/expat/COPYING;md5=7eface865f327188f814c549d44684ad \
- file://src/3rd_party/apache-log4cxx-0.10.0/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
- file://src/3rd_party/apache-log4cxx-0.10.0/site/license.html;md5=09f755b54444a1e59e367ec2437c913c \
- file://src/3rd_party/apache-log4cxx-0.10.0/src/site/doxy/license_notice_footer.txt;md5=00fdad7c9ef761c3dc041b274b267018 \
- file://src/3rd_party-static/jsoncpp/LICENSE;md5=c56ee55c03a55f8105b969d8270632ce \
- file://src/3rd_party-static/jsoncpp/devtools/licenseupdater.py;md5=a85f07940cf61377c9a02202a0ec4480 \
- file://src/3rd_party-static/gmock-1.7.0/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
- file://src/3rd_party-static/gmock-1.7.0/scripts/generator/LICENSE;md5=2c0b90db7465231447cf2dd2e8163333 \
- file://src/3rd_party-static/gmock-1.7.0/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
-
-SRC_URI = "git://github.com/smartdevicelink/sdl_core.git;branch=master"
-
-SRC_URI += " \
- file://0001-add-the-default-cmake-cxx-flag-for-oe.patch \
- file://0002-Use-the-default-install-prefix-of-cmake.patch \
- file://0003-disable-building-sdl-tools.patch \
- file://0004-Change-to-use-standard-libdir.patch \
- file://0005-add-env-for-log4cxx-properties-path.patch \
- file://0006-Install-the-configure-file-to-sysconf-dir.patch \
- file://0007-Add-standard-usr-lib-path-to-rpath.patch \
- file://0008-Unbreak-build-when-BUILD_BT_SUPPORT-OFF.patch \
- file://0009-Function-GetDataOnSessionKey-cannot-be-overloade.patch \
- file://0010-fix-error-of-WriteHandshakeData-return-value.patch \
- file://smartdevicelink.service \
-"
-
-PV = "4.5.1"
-SRCREV = "7f7fcbb998fb17f2954fd103349af67ea9b71a3f"
-
-S = "${WORKDIR}/git"
-
-inherit cmake pythonnative systemd
-
-# The Bluetooth support in the source code is written in terms of Bluez and Pulseaudio. So both must
-# be enabled in the distribution for the option to be activated.
-PACKAGECONFIG_BLUETOOTH ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth pulseaudio', 'bluez5', '', d)}"
-
-# The extended media support uses Pulseaudio
-PACKAGECONFIG_PULSEAUDIO ?= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}"
-
-PACKAGECONFIG ??= "${PACKAGECONFIG_BLUETOOTH} ${PACKAGECONFIG_PULSEAUDIO}"
-
-PACKAGECONFIG[bluez5] = "-DBUILD_BT_SUPPORT=ON,-DBUILD_BT_SUPPORT=OFF,bluez5 pulseaudio,pulseaudio-module-bluetooth-discover pulseaudio-module-bluetooth-policy pulseaudio-module-switch-on-connect pulseaudio-module-bluez5-discover pulseaudio-module-bluez5-device bluez-tools"
-
-PACKAGECONFIG[pulseaudio] = "-DEXTENDED_MEDIA_MODE=ON,-DEXTENDED_MEDIA_MODE=OFF,pulseaudio,pulseaudio-module-alsa-sink"
-
-DEPENDS += "avahi glib-2.0 sqlite3 log4cxx dbus openssl libusb1 bson-c-lib"
-DEPENDS += "gstreamer1.0 gstreamer1.0-plugins-good"
-DEPENDS += "gstreamer1.0-rtsp-server"
-DEPENDS += "boost"
-
-export THIRD_PARTY_INSTALL_PREFIX="${STAGING_DIR_TARGET}"
-export GSTREAMER_DIR="${STAGING_LIBDIR}/gstreamer-1.0"
-EXTRA_OECMAKE += "-DNO_REBUILD_3RD_PARTY=ON"
-EXTRA_OECMAKE += "-DUSE_CCACHE=OFF"
-EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RelWithDebInfo"
-EXTRA_OECMAKE += "-DUSE_GOLD_LD=OFF"
-#FixMe: current with thud openssl 1.1.1. some interfaces were changed disable security...
-EXTRA_OECMAKE += "-DENABLE_SECURITY=OFF"
-
-cmake_do_generate_toolchain_file_append() {
- cat >> ${WORKDIR}/toolchain.cmake <<EOF
-set( CMAKE_SYSTEM_PROCESSOR ${HOST_SYS} )
-EOF
-}
-
-do_install_append() {
- sed -i -e 's:AppConfigFolder =:AppConfigFolder = /etc/smartdevicelink/:g' \
- ${D}/${sysconfdir}/smartdevicelink/smartDeviceLink.ini
- sed -i -e 's:SmartDeviceLinkCore.log:/var/log/smartdevicelink/SmartDeviceLinkCore.log:g' \
- -e 's:TransportManager.log:/var/log/smartdevicelink/TransportManager.log:g' \
- -e 's:ProtocolFordHandling.log:/var/log/smartdevicelink/ProtocolFordHandling.log:g' \
- ${D}/${sysconfdir}/smartdevicelink/log4cxx.properties
-
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/smartdevicelink.service ${D}${systemd_unitdir}/system/smartdevicelink.service
-
- if ${@bb.utils.contains('PACKAGECONFIG', 'bluez5', 'false', 'true', d)}; then
- sed -i -e '/Requires=bluetooth.service/d' \
- -e '/After=bluetooth.service/d' \
- ${D}${systemd_unitdir}/system/smartdevicelink.service
- fi
- fi
-}
-
-SYSTEMD_SERVICE_${PN} = "smartdevicelink.service"
-
-RDEPENDS_${PN} += " bash"
-
-PACKAGES = " \
- ${PN} \
- ${PN}-dev \
- ${PN}-staticdev \
- ${PN}-dbg \
-"
-
-FILES_${PN}_append = " \
- ${libdir}/lib*.so \
-"
-
-INSANE_SKIP_${PN} = "dev-so"
diff --git a/external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb b/external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb
deleted file mode 100644
index bac1740e..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-SUMMARY = "HTML based reference HMI for SmartDeviceLink"
-DESCRIPTION = "SmartDeviceLink (SDL) is a standard set of protocols and \
-messages that connect applications on a smartphone to a vehicle head \
-unit."
-HOMEPAGE = "https://www.smartdevicelink.com"
-SECTION = "app"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=cf455e8d39d2ded1d85b1c5dea6ec3c5"
-
-SRC_URI = "git://github.com/smartdevicelink/generic_hmi.git;branch=develop"
-
-PV = "0.0.0+git${SRCPV}"
-SRCREV = "8d05d53d228d1dec82b78af824e33a0de5697e0c"
-
-S = "${WORKDIR}/git"
-
-PACKAGES = " \
- ${PN} \
-"
-
-FILES_${PN}_append = " \
- ${datadir}/smartdevicelink/generic_hmi/ \
-"
-
-do_install() {
- install -d ${D}${datadir}/smartdevicelink/generic_hmi
- install -m 0644 ${S}/index.html ${D}${datadir}/smartdevicelink/generic_hmi/
- install -d ${D}${datadir}/smartdevicelink/generic_hmi/build
- install -m 0644 ${S}/build/* ${D}${datadir}/smartdevicelink/generic_hmi/build
- install -d ${D}${datadir}/smartdevicelink/generic_hmi/fonts
- install -m 0644 ${S}/fonts/* ${D}${datadir}/smartdevicelink/generic_hmi/fonts
-}
-