summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-02-03 10:55:14 +0000
committerManuel Bachmann <mbc@iot.bzh>2016-02-03 11:12:46 +0000
commit2a50a1ee20d39db50b700e53a550985d69a984a5 (patch)
treec1c0548f75359ca346672717520f14ba52552e27
parentf59c808ae7f7e02dced00d56ef2cbb0acc8a4eb1 (diff)
Remove Yocto 1.7 compatibility crufts
As we are now based upon Yocto 2.0, we can remove lots of backported recipes and contextual patches, which only made sense in the context of Yocto 1.7. Here is the rationale behind each change: - gupnp-dlna: already in meta-openembedded/jethro - ofono: BlueZ 5 compatibility is now working - rygel: already in meta-openembedded/jethro - libgee: already in meta-openembedded/jethro - pulseaudio: BlueZ 5 compatibility is now working - lightmediascanner: already in meta-openembedded/jethro - gpsd: BlueZ 5 compatibility is now working - libmediaart: already in meta-openembedded/jethro - gtest: already in meta-openembedded/jethro - wayland-fits: already in meta-openembedded/jethro PS: "meta-openembedded/meta-efl" is now required because we require the "lightmediascanner" recipe, which is unrelated to EFL but happens to live there. Change-Id: Ib46d152f80b1a8ee5cf848a41e408ece28e6ec65 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--meta-agl/recipes-connectivity/gupnp/gupnp-dlna_0.9.4.bb19
-rw-r--r--meta-agl/recipes-connectivity/ofono/ofono_%.bbappend6
-rw-r--r--meta-agl/recipes-connectivity/rygel/rygel_%.bbappend2
-rw-r--r--meta-agl/recipes-connectivity/rygel/rygel_0.26.1.bb58
-rw-r--r--meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb26
-rw-r--r--meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch11
-rw-r--r--meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb62
-rw-r--r--meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend6
-rw-r--r--meta-agl/recipes-navi-lbs/gpsd/gpsd_%.bbappend4
-rw-r--r--meta-agl/recipes-support/libmediaart/libmediaart-2.0_1.9.0.bb7
-rw-r--r--meta-agl/recipes-support/libmediaart/libmediaart.inc14
-rw-r--r--meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch55
-rw-r--r--meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch39
-rw-r--r--meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb23
-rw-r--r--meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb33
-rw-r--r--templates/intel-corei7-64/conf/bblayers.conf.sample1
-rw-r--r--templates/qemux86-64/conf/bblayers.conf.sample1
-rw-r--r--templates/qemux86/conf/bblayers.conf.sample1
18 files changed, 5 insertions, 363 deletions
diff --git a/meta-agl/recipes-connectivity/gupnp/gupnp-dlna_0.9.4.bb b/meta-agl/recipes-connectivity/gupnp/gupnp-dlna_0.9.4.bb
deleted file mode 100644
index d55e10825..000000000
--- a/meta-agl/recipes-connectivity/gupnp/gupnp-dlna_0.9.4.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Helpers for AV applications using DLNA"
-LICENSE = "LGPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
- file://libgupnp-dlna/gupnp-dlna-profile.h;beginline=1;endline=22;md5=1b85459f65cb1e73a885ca137aab6274"
-
-DEPENDS = "libxml2 glib-2.0"
-
-SRC_URI = "http://download.gnome.org/sources/${BPN}/0.9/${BPN}-${PV}.tar.xz"
-SRC_URI[md5sum] = "f93665e535a512e4d515a86311435cb6"
-SRC_URI[sha256sum] = "69969713f36c0e815fbbbcfdfb3ad9bd447cfd10d0fd86227d82dfd8edb6c807"
-
-inherit autotools pkgconfig
-
-require recipes-connectivity/gupnp/no-vala.inc
-
-PACKAGECONFIG ?= "gstreamer"
-PACKAGECONFIG[gstreamer] = "--enable-gstreamer-metadata-backend,--disable-gstreamer-metadata-backend,gstreamer1.0 gstreamer1.0-plugins-base"
-
-FILES_${PN} += "${datadir}/gupnp-dlna-2.0/dlna-profiles"
diff --git a/meta-agl/recipes-connectivity/ofono/ofono_%.bbappend b/meta-agl/recipes-connectivity/ofono/ofono_%.bbappend
deleted file mode 100644
index ab25a74ce..000000000
--- a/meta-agl/recipes-connectivity/ofono/ofono_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Prevent BlueZ 4 from being always pulled
-DEPENDS_remove = "bluez4"
-
-# If Bluetooth is asked in DISTRO_FEATURES, verify if Bluez 5 is also
-# explicitly specified. If it is not, fall back to BlueZ 4
-DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5', 'bluez4', d), '', d)}"
diff --git a/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend b/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
index 9d4713ce1..8294978a5 100644
--- a/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
+++ b/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
@@ -1,3 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
# Disable everything but the media-export plugin, add the lms plugin
PACKAGECONFIG = "media-export lms"
PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin,sqlite3"
diff --git a/meta-agl/recipes-connectivity/rygel/rygel_0.26.1.bb b/meta-agl/recipes-connectivity/rygel/rygel_0.26.1.bb
deleted file mode 100644
index 205e900e2..000000000
--- a/meta-agl/recipes-connectivity/rygel/rygel_0.26.1.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-SUMMARY = "A UPnP AV media server and renderer"
-DESCRIPTION = "Rygel is a home media solution (UPnP AV MediaServer) that \
-allow you to easily share audio, video and pictures to other devices. \
-Additionally, media player software may use Rygel to become a MediaRenderer \
-that may be controlled remotely by a UPnP or DLNA Controller."
-HOMEPAGE = "http://live.gnome.org/Rygel"
-
-LICENSE = "LGPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
- file://src/rygel/rygel-main.vala;endline=25;md5=a4cce4d389da1c1638fe68d07ae9d811"
-
-DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base ossp-uuid libgee-0.8 libsoup-2.4 libmediaart-2.0"
-RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info"
-
-GNOME_COMPRESS_TYPE = "xz"
-SRC_URI[archive.md5sum] = "f182d54913a528bb5b4fb2f291aca0fc"
-SRC_URI[archive.sha256sum] = "390740609e34399b886ddb9a8f7eca25055ad72048dfdd869edf02999b1e1d8f"
-
-inherit gnomebase vala
-
-EXTRA_OECONF = "--disable-introspection --disable-tracker-plugin --with-media-engine=gstreamer"
-
-PACKAGECONFIG ?= "external mpris mediathek ruih media-export gst-launch gtk+3"
-PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin"
-PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin"
-PACKAGECONFIG[mediathek] = "--enable-mediathek-plugin,--disable-mediathek-plugin"
-PACKAGECONFIG[ruih] = "--enable-ruih-plugin,--disable-ruih-plugin"
-PACKAGECONFIG[media-export] = "--enable-media-export-plugin,--disable-media-export-plugin,sqlite3"
-PACKAGECONFIG[gst-launch] = "--enable-gst-launch-plugin,--disable-gst-launch-plugin"
-PACKAGECONFIG[gtk+3] = ",--without-ui,gtk+3"
-
-LIBV = "2.6"
-
-do_install_append() {
- # Remove .la files for loadable modules
- rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la
- rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la
-}
-
-FILES_${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons"
-FILES_${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug"
-
-PACKAGES += "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
-
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
-
-python populate_packages_prepend () {
- rygel_libdir = d.expand('${libdir}/rygel-${LIBV}')
- postinst = d.getVar('plugin_postinst', True)
- pkgs = []
-
- pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), 'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
- pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
-
- metapkg = d.getVar('PN', True) + '-meta'
- d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
-}
diff --git a/meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb b/meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb
deleted file mode 100644
index 3cf16e309..000000000
--- a/meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "libgee is a collection library providing GObject-based interfaces \
-and classes for commonly used data structures."
-HOMEPAGE = "http://live.gnome.org/Libgee"
-SECTION = "libs"
-DEPENDS = "glib-2.0 gobject-introspection-stub"
-
-BBCLASSEXTEND = "native"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-
-PE = "1"
-
-inherit autotools vala pkgconfig
-do_configure_prepend() {
- MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
- for i in ${MACROS}; do
- rm -f m4/$i
- done
-}
-
-SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
-SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/libgee-${PV}.tar.xz"
-SRC_URI[md5sum] = "d30cf203784431b0fdc3216b1acd999c"
-SRC_URI[sha256sum] = "d95f8ea8e78f843c71b1958fa2fb445e4a325e4821ec23d0d5108d8170e564a5"
-
-S = "${WORKDIR}/libgee-${PV}"
diff --git a/meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch b/meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch
deleted file mode 100644
index 9528bec79..000000000
--- a/meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/plugins/Makefile.am 2015-10-25 16:12:29.331415823 +0000
-+++ b/src/plugins/Makefile.am 2015-10-25 16:14:37.593415808 +0000
-@@ -93,7 +93,7 @@
- id3_id3_la_SOURCES = id3/id3.c id3/id3v1_genres.c
- id3_id3_la_LIBADD = $(PLUGINS_LIBADD)
-
--id3/id3v1_genres.c: $(srcdir)/id3/id3v1_genres.def $(srcdir)/id3/id3v1_genres_gen.awk
-+$(srcdir)/id3/id3v1_genres.c: $(srcdir)/id3/id3v1_genres.def $(srcdir)/id3/id3v1_genres_gen.awk
- $(AWK) -f $(srcdir)/id3/id3v1_genres_gen.awk $(srcdir)/id3/id3v1_genres.def > $@
-
- EXTRA_DIST += id3/id3v1_genres.def id3/id3v1_genres_gen.awk
diff --git a/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb b/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
deleted file mode 100644
index 9870fac3d..000000000
--- a/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
+++ /dev/null
@@ -1,62 +0,0 @@
-SUMMARY = "Lightweight media scanner"
-DESCRIPTION = "Lightweight media scanner meant to be used in not-so-powerful devices, like embedded systems or old machines."
-SECTION = "libs/multimedia"
-
-LICENSE = "LGPLv2.1+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
- file://src/lib/lightmediascanner.c;endline=21;md5=6d8889bccb4c6c27e8b786342a3eb267"
-
-DEPENDS = "file gawk glib-2.0 sqlite3"
-
-PV = "0.5.1+git${SRCPV}"
-SRCREV = "adfddb3486276a5ed2f5008c9e43a811e1271cc9"
-SRC_URI = "git://github.com/profusion/lightmediascanner.git \
- file://id3-plugin-support-out-of-tree-build.patch \
- "
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--enable-static --disable-mp4"
-
-PACKAGECONFIG ??= "ogg flac wave id3 m3u pls asf rm jpeg png"
-PACKAGECONFIG[generic] = "--enable-generic,--disable-generic,libav"
-PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg libvorbis libtheora"
-PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
-PACKAGECONFIG[wave] = "--enable-wave,--disable-wave"
-PACKAGECONFIG[id3] = "--enable-id3,--disable-id3"
-PACKAGECONFIG[m3u] = "--enable-m3u,--disable-m3u"
-PACKAGECONFIG[pls] = "--enable-pls,--disable-pls"
-PACKAGECONFIG[asf] = "--enable-asf,--disable-asf"
-PACKAGECONFIG[rm] = "--enable-rm,--disable-rm"
-PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg"
-PACKAGECONFIG[png] = "--enable-png,--disable-png"
-
-do_install_append() {
- # Install "test" binary for corresponding package
- install -d ${D}/${bindir}
- install -m 755 ${B}/src/bin/.libs/test ${D}/${bindir}/test-lms
- # Remove .la files for loadable modules
- rm -f ${D}/${libdir}/${PN}/plugins/*.la
-}
-
-FILES_${PN} += "${datadir}/dbus-1"
-FILES_${PN}-dbg += "${libdir}/${PN}/plugins/.debug"
-
-PACKAGES_prepend = "${PN}-test "
-FILES_${PN}-test_prepend = "${bindir}/test-lms "
-
-PACKAGES += "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
-
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
-
-python populate_packages_prepend () {
- lms_libdir = d.expand('${libdir}/${PN}')
- pkgs = []
-
- pkgs += do_split_packages(d, oe.path.join(lms_libdir, "plugins"), '^(.*)\.so$', d.expand('${PN}-plugin-%s'), 'LightMediaScanner plugin for %s', prepend=True, extra_depends=d.expand('${PN}'))
- metapkg = d.getVar('PN', True) + '-meta'
- d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
-}
diff --git a/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
deleted file mode 100644
index fd7b84986..000000000
--- a/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Prevent BlueZ 4 from being always pulled
-PACKAGECONFIG_remove = "bluez4"
-
-# If Bluetooth is asked in DISTRO_FEATURES, verify if Bluez 5 is also
-# explicitly specified. If it is not, fall back to BlueZ 4
-PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5', 'bluez4', d), '', d)}"
diff --git a/meta-agl/recipes-navi-lbs/gpsd/gpsd_%.bbappend b/meta-agl/recipes-navi-lbs/gpsd/gpsd_%.bbappend
deleted file mode 100644
index 2e97174f3..000000000
--- a/meta-agl/recipes-navi-lbs/gpsd/gpsd_%.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-# If Bluetooth is asked in DISTRO_FEATURES, verify if Bluez 5 is also
-# explicitly specified. If it is not, fall back to BlueZ 4
-BLUEZ_CONFIG = "bluez='true',bluez='false',${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5', 'bluez4', d), '', d)}"
-PACKAGECONFIG[bluez] := "${BLUEZ_CONFIG}"
diff --git a/meta-agl/recipes-support/libmediaart/libmediaart-2.0_1.9.0.bb b/meta-agl/recipes-support/libmediaart/libmediaart-2.0_1.9.0.bb
deleted file mode 100644
index 44f135a21..000000000
--- a/meta-agl/recipes-support/libmediaart/libmediaart-2.0_1.9.0.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require libmediaart.inc
-
-SRC_URI = "${GNOME_MIRROR}/libmediaart/1.9/libmediaart-${PV}.tar.xz"
-SRC_URI[md5sum] = "0b65d64398d2f3dff89534c9dfffab4f"
-SRC_URI[sha256sum] = "94668adb29d4dc3115b0fd105942ebd5ca6f5f9dbb2afa8a191a73a747dd506f"
-
-S = "${WORKDIR}/libmediaart-${PV}"
diff --git a/meta-agl/recipes-support/libmediaart/libmediaart.inc b/meta-agl/recipes-support/libmediaart/libmediaart.inc
deleted file mode 100644
index a117e9ba5..000000000
--- a/meta-agl/recipes-support/libmediaart/libmediaart.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Library tasked with managing, extracting and handling media art caches"
-
-LICENSE = "LGPLv2+ & GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=4fbd65380cdd255951079008b364516c \
- file://libmediaart/extract.c;endline=18;md5=dff2b6328ab067b5baadc135f9876c36 \
- file://tests/mediaarttest.c;endline=18;md5=067106eaa1f7a9d918759a096667f18e"
-
-DEPENDS = "glib-2.0 gdk-pixbuf"
-
-GNOME_COMPRESS_TYPE = "xz"
-
-inherit gnomebase gtk-doc
-
-EXTRA_OECONF = "--disable-introspection --disable-qt --enable-gdkpixbuf"
diff --git a/meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch b/meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
deleted file mode 100644
index 1ece136b6..000000000
--- a/meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From d4b25ce723812faf78d8ee038b7cbed00cbba682 Mon Sep 17 00:00:00 2001
-From: Rodrigo Caimi <caimi@datacom.ind.br>
-Date: Tue, 7 Oct 2014 15:37:10 -0300
-Subject: [PATCH] CMakeLists, gtest.pc.in: Add pkg-config support to gtest
- 1.7.0
-
-Signed-off-by: Rodrigo Caimi <caimi@datacom.ind.br>
----
- CMakeLists.txt | 6 ++++++
- gtest.pc.in | 9 +++++++++
- 2 files changed, 15 insertions(+)
- create mode 100644 gtest.pc.in
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 281c4c2..e4354a8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -29,6 +29,9 @@ if (COMMAND pre_project_set_up_hermetic_build)
- pre_project_set_up_hermetic_build()
- endif()
-
-+# pkg-config support
-+configure_file("gtest.pc.in" "gtest.pc" @ONLY)
-+
- ########################################################################
- #
- # Project-wide settings
-@@ -75,6 +78,9 @@ target_link_libraries(gtest_main gtest)
-
- install(TARGETS gtest DESTINATION lib)
- install(TARGETS gtest_main DESTINATION lib)
-+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gtest.pc"
-+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig/"
-+)
-
- ########################################################################
- #
-diff --git a/gtest.pc.in b/gtest.pc.in
-new file mode 100644
-index 0000000..57b1049
---- /dev/null
-+++ b/gtest.pc.in
-@@ -0,0 +1,9 @@
-+Name: libgtest
-+Version: 1.7.0
-+Description: Google's framework for writing C++ tests on a variety of platforms
-+
-+prefix=@CMAKE_INSTALL_PREFIX@
-+includedir=${prefix}/include
-+libdir=${prefix}/lib
-+Cflags:-I${includedir}/gtest
-+Libs: -L${libdir} -lgtest -lgtest_main
---
-1.9.1
-
diff --git a/meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch b/meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
deleted file mode 100644
index 0c160b02a..000000000
--- a/meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 5318983562be6babeb5a6996e7dda4b31acfdba8 Mon Sep 17 00:00:00 2001
-From: Otavio Salvador <otavio@ossystems.com.br>
-Date: Wed, 30 Jul 2014 16:49:53 -0300
-Subject: [PATCH] cmake: Add install command for libraries and headers
-Organization: O.S. Systems Software LTDA.
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 57470c8..281c4c2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -56,6 +56,8 @@ include_directories(
- ${gtest_SOURCE_DIR}/include
- ${gtest_SOURCE_DIR})
-
-+install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest DESTINATION include)
-+
- # Where Google Test's libraries can be found.
- link_directories(${gtest_BINARY_DIR}/src)
-
-@@ -71,6 +73,9 @@ cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
- cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
- target_link_libraries(gtest_main gtest)
-
-+install(TARGETS gtest DESTINATION lib)
-+install(TARGETS gtest_main DESTINATION lib)
-+
- ########################################################################
- #
- # Samples on how to link user tests with gtest or gtest_main.
---
-1.9.1
-
diff --git a/meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb b/meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb
deleted file mode 100644
index 9f148d549..000000000
--- a/meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Google's framework for writing C++ tests"
-HOMEPAGE = "http://code.google.com/p/googletest/"
-SECTION = "libs"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
-
-SRC_URI = "\
- http://googletest.googlecode.com/files/${BPN}-${PV}.zip \
- file://cmake-Add-install-command-for-libraries-and-headers.patch \
- file://CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch \
-"
-
-SRC_URI[md5sum] = "2d6ec8ccdf5c46b05ba54a9fd1d130d7"
-SRC_URI[sha256sum] = "247ca18dd83f53deb1328be17e4b1be31514cedfc1e3424f672bf11fd7e0d60d"
-
-inherit lib_package cmake
-
-ALLOW_EMPTY_${PN} = "1"
-ALLOW_EMPTY_${PN}-dbg = "1"
-
-RDEPENDS_${PN}-dev += "${PN}-staticdev"
-
-BBCLASSEXTEND = "nativesdk"
diff --git a/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb b/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb
deleted file mode 100644
index 3a4f8a2ca..000000000
--- a/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "Wayland-fits, the Wayland Functional Integration Test Suite"
-DESCRIPTION = "Wayland-fits is a fully automated functional integration \
-test suite. Its main purpose is to test the functionality and integration of \
-client-side (i.e. toolkit) and server-side (compositor) implementations of \
-the Wayland protocol."
-HOMEPAGE = "https://github.com/01org/wayland-fits"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=f8d34cadaf891753c0f00c6cd48f08f5 \
- file://src/extensions/weston/weston-wfits.cpp;endline=21;md5=848c81e55cf3a30a9f6ed75f0dba7a97"
-
-SRC_URI = "git://github.com/01org/wayland-fits.git"
-SRCREV = "f30dfa9fceb438d3687c5215093fffc21a7852fc"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-DEPENDS = "libcheck boost wayland weston"
-RDEPENDS_${PN} = "weston"
-
-EXTRA_OECONF += "--enable-shared --disable-static --with-boost-libdir=${STAGING_LIBDIR}"
-
-PACKAGECONFIG ??= "elementary gtk+3"
-
-PACKAGECONFIG[elementary] = "--enable-efl-tests,--disable-efl-tests,elementary"
-PACKAGECONFIG[gtk+3] = "--enable-gtk-tests,--disable-gtk-tests,gtk+3"
-
-do_install_append() {
- rm -f ${D}/${libdir}/weston/*.la
-}
-
-FILES_${PN} += "${bindir}/wfits ${libdir}/weston/*.so"
-FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/weston/.debug ${prefix}/src"
diff --git a/templates/intel-corei7-64/conf/bblayers.conf.sample b/templates/intel-corei7-64/conf/bblayers.conf.sample
index 668f0fe98..cece87e1e 100644
--- a/templates/intel-corei7-64/conf/bblayers.conf.sample
+++ b/templates/intel-corei7-64/conf/bblayers.conf.sample
@@ -14,6 +14,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-agl/meta-agl-bsp \
##OEROOT##/../meta-openembedded/meta-oe \
##OEROOT##/../meta-openembedded/meta-multimedia \
+ ##OEROOT##/../meta-openembedded/meta-efl \
##OEROOT##/../meta-intel \
"
BBLAYERS_NON_REMOVABLE ?= " \
diff --git a/templates/qemux86-64/conf/bblayers.conf.sample b/templates/qemux86-64/conf/bblayers.conf.sample
index e5e54431c..ba2f197c8 100644
--- a/templates/qemux86-64/conf/bblayers.conf.sample
+++ b/templates/qemux86-64/conf/bblayers.conf.sample
@@ -14,6 +14,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-agl/meta-agl-bsp \
##OEROOT##/../meta-openembedded/meta-oe \
##OEROOT##/../meta-openembedded/meta-multimedia \
+ ##OEROOT##/../meta-openembedded/meta-efl \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/qemux86/conf/bblayers.conf.sample b/templates/qemux86/conf/bblayers.conf.sample
index e5e54431c..ba2f197c8 100644
--- a/templates/qemux86/conf/bblayers.conf.sample
+++ b/templates/qemux86/conf/bblayers.conf.sample
@@ -14,6 +14,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-agl/meta-agl-bsp \
##OEROOT##/../meta-openembedded/meta-oe \
##OEROOT##/../meta-openembedded/meta-multimedia \
+ ##OEROOT##/../meta-openembedded/meta-efl \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \