summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-aglprofilegraphical
diff options
context:
space:
mode:
authorPaul Barker <pbarker@konsulko.com>2019-11-10 00:39:42 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-03 15:09:19 +0000
commit2fa5dae62868c63781568eeb5435ed3296c2ddc2 (patch)
treea18cfd9ea20e61b3093b4d1ca6d9ad850dab96eb /meta-agl-bsp/meta-aglprofilegraphical
parent11a613bab398e60d8a9da1eb0d6c4c754fd8bfef (diff)
Extend intel-corei7-64 machine to support virtual targets
These changes allow images built for the intel-corei7-64 machine to be booted under qemu (by using the normal `runqemu` command) and vmware or virtualbox after a build. Functionality on real hardware should not be compromised. Bug-AGL: SPEC-2931 Change-Id: If25782bf59e145cab32a4c9a0e39b599106ce7cc Signed-off-by: Paul Barker <pbarker@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-aglprofilegraphical')
-rw-r--r--meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend1
-rw-r--r--meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend3
2 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend
index 49e527707..8ac343aa3 100644
--- a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend
@@ -2,5 +2,6 @@
GALLIUM_LLVM = "gallium-llvm"
PACKAGECONFIG_append_qemux86 = " gallium ${GALLIUM_LLVM}"
PACKAGECONFIG_append_qemux86-64 = " gallium ${GALLIUM_LLVM}"
+PACKAGECONFIG_append_intel-corei7-64 = " gallium ${GALLIUM_LLVM}"
DRIDRIVERS_append_intel-corei7-64 = ",i965"
diff --git a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend
index 8fa08bc3b..916bd6f3d 100644
--- a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -7,3 +7,6 @@ OVERRIDES_prepend_qemux86-64 = "virtualmachine:"
# Switch to the Virtual section that we have when a valid DRM device is found
SRC_URI_remove_virtualmachine = "file://hdmi-a-1-270.cfg"
SRC_URI_append_virtualmachine = " file://virtual.cfg"
+
+# For intel-corei7-64 we want to support both the HDMI-A-1 and Virtual-1 outputs
+SRC_URI_append_intel-corei7-64 = " file://virtual.cfg"