summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
diff options
context:
space:
mode:
authorCorentin Labbe <clabbe@baylibre.com>2019-06-17 13:18:06 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-21 11:30:54 +0000
commit075d872edc9fbec1463e0ef164a2db88f5f5427b (patch)
tree406727f21d0a0d9c17d323e67e4bab6ffe955e97 /meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
parent576cd930a78ab554cf3d805e65b9cf13d1d77ade (diff)
SPEC-2376: Add config for QEMU arm kernels
The default yocto qemuarm machine is versatilepb which is not the right choice for AGL (ex: Max 256M of RAM). This patchs change qemuarm configs for using the virt machine. Change-Id: Ib5e0ae801ba152318a2455763b1a2f1020d1858e Bug-AGL: SPEC-2376 Signed-off-by: Corentin Labbe <clabbe@baylibre.com>
Diffstat (limited to 'meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
index d8a583926..e97b8f9d1 100644
--- a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -8,6 +8,9 @@ SRC_URI += "file://hciattach.cfg \
# Enable some things on qemuarm64 so MOST drivers will build and load.
SRC_URI_append_qemuarm64 = " file://most_deps.cfg"
+# Configuration for using the virt machine (and not versatilepb)
+SRC_URI_append_qemuarm = " file://qemuarm.cfg"
+
# Build a generic v7 kernel instead of the arm926j one that upstream
# qemuarm defaults to.
KBUILD_DEFCONFIG_qemuarm = "multi_v7_defconfig"