summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
authorKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-03 10:26:26 +0900
committerKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-03 10:26:26 +0900
commit0a34b88c4b661a91962dd0c04c3af7e582bafcbd (patch)
treeeaa2e7f0725efe029e1bc9fcfc8548b035987b1a /meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
parent99804790f0954fc2cf0d20aa4d0a581361d3cfe6 (diff)
weston: Set XDG_RUNTIME_DIR for qcom
Without this environment variable, Weston fails to start on Dragonboard Change-Id: I8863b79c47cde44d7830bc51e4ddc1be64eaff65 Signed-off-by: Kotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>
Diffstat (limited to 'meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..8fff1dfe7
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-qcom.ini \
+ file://weston.sh \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-qcom.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ ${sysconfdir}/profile.d/weston.sh \
+ "