summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2019-07-23 19:17:29 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-07-24 18:42:24 +0000
commit07af9fef1e30e5220a940c2c7e19e4bc50b9b456 (patch)
tree740183b48d84725da48006a77bea8a73071f08ba /meta-agl-bsp/meta-raspberrypi
parent5b23f8e5015e4b79f127d91fd0792dbb6a352c94 (diff)
bcm2835-bootfiles.bbappend: Support Raspberry Pi 4
Use different bootfiles if the machine has been set to the new Raspberry Pi 4 and keep the old files for Raspberry Pi 3. Bug-AGL: SPEC-2656 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Change-Id: I3cbacc45c0f82ce2c70641c008ad2975a9e58fbd
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
index adb19c09c..009c448bc 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
@@ -1 +1,12 @@
RDEPENDS_${PN}_append_sota += " u-boot-otascript"
+
+RPIFW_DATE_raspberrypi4 = "20190709"
+SRCREV_raspberrypi4 = "356f5c2880a3c7e8774025aa6fc934a617553e7b"
+RPIFW_SRC_URI_raspberrypi4 = "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz"
+RPIFW_S_raspberrypi_4 = "${WORKDIR}/firmware-${SRCREV}"
+
+SRC_URI_raspberrypi4 = "${RPIFW_SRC_URI}"
+SRC_URI[md5sum] = "${@ '5962784e7963f0116cd1519e47749b25' if d.getVar('MACHINE_ARCH') == 'raspberrypi4' else '5ccdb5447cbdd3ee0158a514f7b76cb9'}"
+SRC_URI[sha256sum] = "${@ '6e07d98e4229ba7a1970a4c475fc6b8631823d200d3b8734a508e7ff5ea4c120' if d.getVar('MACHINE_ARCH') == 'raspberrypi4' else '9a34ccc4a51695a33206cc6c8534f615ba5a30fcbce5fa3add400ecc6b80ad8a'}"
+
+PV_raspberrypi4 = "${RPIFW_DATE}"