summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-02-20 11:00:49 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-27 10:11:51 +0000
commita29f0388d7d3c84b5a41f307060fddf963078e24 (patch)
treedf32bde745116879673d5555b887f440ec0c67cf /meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb
parent091b39560ec03248f7836f79e66406989fdaedfa (diff)
Add OTA wks support to Porter and RCar-M3 boards
Bug-AGL: SPEC-413 Change-Id: I4ef71fde4a013c1dac4917f66727ce4b6be4170c Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb
new file mode 100644
index 000000000..f0e04c06a
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Boot files (bootscripts etc.) for Renesas RCar-M3 board"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit deploy
+
+COMPATIBLE_MACHINE = "m3ulcb"
+
+S = "${WORKDIR}"
+
+SRC_URI_append_sota = "file://uEnv-ota.txt"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/${PN}
+}
+
+do_deploy_append_sota() {
+ install -m 0755 ${WORKDIR}/uEnv-ota.txt ${DEPLOYDIR}/${PN}/uEnv.txt
+}
+
+addtask deploy before do_package after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+