summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-04-12 14:07:33 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-19 11:18:50 +0000
commit029de35a172da31b083b86d93a79d787773dec11 (patch)
treed49ead563efec4f599900dd4abfca4c4dd14476a /meta-agl-bsp/meta-ti
parent473b4354758ea6657fd196c30fb14332b5e7178d (diff)
Use weston-init to startup weston
* weston.service should not be a part of weston recipes * remove weston.service from AGL weston recipes * yocto upstream uses the recipe weston-init to startup weston * customize weston-start with sed - remove openvt - add option to weston-launch * customize weston.service with sed - add option for weston * unified the weston startup beteween AGL BSPs * remove fix on the AGL BSP Bug-AGL: SPEC-452 Bug-AGL: SPEC-310 Change-Id: I12722826abdc004214d289961e900c36528ec6e3 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-ti')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend15
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init108
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston39
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service13
4 files changed, 0 insertions, 175 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend
deleted file mode 100644
index 041e5abe1..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-PR_append = ".arago7"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI_append = " \
- file://runWeston \
-"
-
-do_install_append() {
- install -d ${D}${bindir}
- install -m 755 ${WORKDIR}/runWeston ${D}${bindir}
- rm -rf ${D}${systemd_system_unitdir}
-}
-
-SYSTEMD_SERVICE_${PN} = ""
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init b/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init
deleted file mode 100644
index 336e5af81..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/bin/sh
-#
-### BEGIN INIT INFO
-# Provides: weston
-# Required-Start: $local_fs $remote_fs
-# Required-Stop: $local_fs $remote_fs
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-### END INIT INFO
-
-killproc() {
- pid=`/bin/pidof $1`
- [ "$pid" != "" ] && kill $pid
-}
-
-read CMDLINE < /proc/cmdline
-for x in $CMDLINE; do
- case $x in
- weston=false)
- echo "Weston disabled"
- exit 0;
- ;;
- esac
-done
-
-case "$1" in
- start)
- . /etc/profile
-
- # Weston for some reason dies if these environment variables are set
- unset WAYLAND_DISPLAY
-
- # This is all a nasty hack
- if test -z "$XDG_RUNTIME_DIR"; then
- export XDG_RUNTIME_DIR=/run/user/root
- fi
-
- if [ ! -d "$XDG_RUNTIME_DIR" ] ; then
- mkdir --parents $XDG_RUNTIME_DIR
- chmod 0700 $XDG_RUNTIME_DIR
- fi
-
- openvt -c 4 -f runWeston
-
- # If there's no touchscreen device available, done
- if [ ! -e /dev/input/touchscreen0 ] ; then
- exit 0
- fi
-
- # If it was already calibrated, done
- if [ -f "$WS_CALUDEV_FILE" ] ; then
- exit 0
- fi
-
- # Check if SD card is mounted
- mount | grep /run/media/mmcblk0p1 | grep vfat > /dev/null 2>&1
- if [ "$?" = "0" ] ; then
- SD_MOUNTED="1"
- else
- SD_MOUNTED="0"
- fi
-
- # Check if SD card has a calibration rules file
- SD_CALUDEV_FILE=/run/media/mmcblk0p1/ws-calibrate.rules
- if [ "$SD_MOUNTED" = "1" -a -f "$SD_CALUDEV_FILE" ] ; then
- # Copy it over to udev location
- cp "$SD_CALUDEV_FILE" "$WS_CALUDEV_FILE"
- else
- # Run a calibration app and save output to udev rules
- echo "Calibrating touchscreen (first time only)"
- echo
- echo "*** To continue, please complete the touchscreen calibration"
- echo -n "*** by touching the crosshairs on the LCD screen"
- sleep 1
- CAL_VALUES=`weston-calibrator|cut -c21-`
- echo 'SUBSYSTEM=="input", ENV{WL_CALIBRATION}="'$CAL_VALUES'"' > $WS_CALUDEV_FILE
- echo "."
- # Copy it back to SD
- if [ "$SD_MOUNTED" = "1" ] ; then
- cp "$WS_CALUDEV_FILE" "$SD_CALUDEV_FILE"
- fi
- fi
-
- # Reload and re-run udev rules and restart weston
- udevadm control --reload
- udevadm trigger
- killproc weston
- sleep 2
- openvt -c 4 -f runWeston
- ;;
-
- stop)
- echo "Stopping Weston"
- killproc weston
- ;;
-
- restart)
- $0 stop
- sleep 2
- $0 start
- ;;
-
- *)
- echo "usage: $0 { start | stop | restart }"
- ;;
-esac
-
-exit 0
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston b/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston
deleted file mode 100644
index aed5d5f91..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/sh
-
-clear
-cat << EOF
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
- Please wait...
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-EOF
-
-weston --idle-time=0 >> /var/log/weston.log 2>&1
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service
deleted file mode 100644
index cec707d56..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Weston reference Wayland compositor
-Conflicts=getty@tty1.service
-After=dbus.service rc.pvr.service
-
-[Service]
-ExecStart=/usr/bin/weston-launch -u root -- --backend=drm-backend.so --idle-time=4294967 --config=/etc/xdg/weston/weston.ini
-ExecStop=/usr/bin/killall -s KILL weston
-Restart=always
-Type=simple
-
-[Install]
-WantedBy=multi-user.target