summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-kernel
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-07-01 02:21:58 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-07-02 19:05:17 +0200
commit1f7c63cb0f2d85325d7dcc7b49cd3038e395b42a (patch)
treeea8f6e1a6a88f8338008dcd19cc7bb4055e57535 /meta-agl-bsp/recipes-kernel
parent3fb78c5ff1b63c5c4703efde2dc405d897fda74c (diff)
Cleanup of recipes - part 2
- meta-core is a duplication, move right into meta-agl-bsp/recipes-* - u-boot-otascript is now part of meta-updater-raspberrypi - u-boot-ota_2015.07 is replaced with meta-updater-qemux86-64 - opencv is now in meta-oe - move virtualization-layer to 'meta-virtualization-layer' for consistency all dynamic included layers start with 'meta-' Bug-AGL: SPEC-3468 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Id56f1b60757b304c29ba7a8e11934a6dbf56f129
Diffstat (limited to 'meta-agl-bsp/recipes-kernel')
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/hciattach.cfg17
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/most_deps.cfg9
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/qemuarm.cfg6
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/virtio.cfg6
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend18
5 files changed, 56 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/hciattach.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/hciattach.cfg
new file mode 100644
index 000000000..c9c4fe2ed
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/hciattach.cfg
@@ -0,0 +1,17 @@
+#
+# Bluetooth device drivers
+#
+CONFIG_BT_INTEL=m
+CONFIG_BT_BCM=m
+CONFIG_BT_RTL=m
+CONFIG_BT_HCIBTUSB=m
+CONFIG_BT_HCIBTUSB_BCM=y
+CONFIG_BT_HCIBTUSB_RTL=y
+CONFIG_BT_HCIUART=m
+CONFIG_BT_HCIUART_H4=y
+CONFIG_BT_HCIUART_BCSP=y
+
+#
+# USB port drivers
+#
+CONFIG_USB_SERIAL_CP210X=y
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/most_deps.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/most_deps.cfg
new file mode 100644
index 000000000..15ddbd21e
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/most_deps.cfg
@@ -0,0 +1,9 @@
+CONFIG_I2C=y
+CONFIG_USB=y
+CONFIG_MEDIA_SUPPORT=m
+CONFIG_MEDIA_CAMERA_SUPPORT=y
+CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
+CONFIG_MEDIA_CONTROLLER=y
+CONFIG_VIDEO_DEV=m
+CONFIG_VIDEO_V4L2_SUBDEV_API=y
+CONFIG_VIDEO_V4L2=m
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/qemuarm.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/qemuarm.cfg
new file mode 100644
index 000000000..e71c714d6
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/qemuarm.cfg
@@ -0,0 +1,6 @@
+# Necessary configs for using the virt qemu machine
+CONFIG_ARCH_MULTI_V7=y
+CONFIG_ARCH_VIRT=y
+CONFIG_SERIAL_AMBA_PL011=y
+CONFIG_PCI_HOST_GENERIC=y
+CONFIG_RTC_DRV_PL031=y
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/virtio.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/virtio.cfg
new file mode 100644
index 000000000..d042d7d64
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/virtio.cfg
@@ -0,0 +1,6 @@
+# qemu need a virtio storage for rootfs
+CONFIG_BLK_MQ_VIRTIO=y
+CONFIG_VIRTIO=y
+CONFIG_VIRTIO_BLK=y
+# qemuarm need virtionet
+CONFIG_VIRTIO_NET=y
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
index 386112024..8d0c0ad06 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -1 +1,19 @@
require linux-agl.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
+
+# Extra configuration options for the QEMU kernel
+SRC_URI += "file://hciattach.cfg \
+ file://virtio.cfg \
+ "
+
+# Enable some things on qemuarm64 so MOST drivers will build and load.
+SRC_URI_append_qemuarm64 = " file://most_deps.cfg"
+
+# Configuration for using the virt machine (and not versatilepb)
+SRC_URI_append_qemuarm = " file://qemuarm.cfg"
+
+# Build a generic v7 kernel instead of the arm926j one that upstream
+# qemuarm defaults to.
+KBUILD_DEFCONFIG_qemuarm = "multi_v7_defconfig"
+KCONFIG_MODE = "--alldefconfig"