summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-kernel/most/most.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-27 13:31:58 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-27 13:31:58 -0500
commitb7fdcead5a738b986d74ba8c00be88fe7a44af74 (patch)
tree9b2d6e2e109e12c2a33605c6de4aa8d61012dfc2 /meta-agl-profile-core/recipes-kernel/most/most.bbappend
parent6aeb440d5e1e5155c866e91c3ec0f978122e8862 (diff)
meta-agl-profile-core: update most recipe
Update SRCREV in MOST driver recipe to pick up: e4dbbaf sound.c: Remove snd_pcm_lib_mmap_vmalloc As well, the following changes have been made to the bbappend: - the kernel version detection logic has been removed - the patch to support kernels older than 4.13 has been removed - the patch that was handling the snd_pcm_lib_mmap_vmalloc issue on kernels >= 4.19 has been reworked to add the required #ifdefs to support kernels < 4.19 for e.g. the rcar3 4.14-ltsi kernel. Bug-AGL: SPEC-2932 Change-Id: I388d186d04ccc017ff10b2024ae35ed22f7a8e36 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core/recipes-kernel/most/most.bbappend')
-rw-r--r--meta-agl-profile-core/recipes-kernel/most/most.bbappend21
1 files changed, 2 insertions, 19 deletions
diff --git a/meta-agl-profile-core/recipes-kernel/most/most.bbappend b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
index 17ad05585..b96625229 100644
--- a/meta-agl-profile-core/recipes-kernel/most/most.bbappend
+++ b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
@@ -1,21 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-def prep_version (d) :
- KV = d.getVar('KERNEL_VERSION', True)
- if not KV :
- return "4.12"
- else:
- return KV
-
-ORIG_KERN_VER = "${@prep_version(d)}"
-
-VANILLA_KERNEL_VERSION = "${@str(ORIG_KERN_VER.split("-")[0].split(".")[0]+ORIG_KERN_VER.split("-")[0].split(".")[1])}"
-
-APPLY = "${@str('no' if ${VANILLA_KERNEL_VERSION} > 412 else 'yes')}"
-APPLY_419 = "${@str('no' if ${VANILLA_KERNEL_VERSION} < 419 else 'yes')}"
-
SRC_URI_append = " \
- file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
file://0002-src-most-add-auto-conf-feature.patch \
file://0003-core-remove-kernel-log-for-MBO-status.patch \
file://0004-most-video-set-device_caps.patch \
@@ -25,7 +10,5 @@ SRC_URI_append = " \
file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
file://0010-backport-usb-setup-timer.patch \
- file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
- "
-# Make sure we can expose KERNEL_VERSION ...
-do_patch[depends] += "virtual/kernel:do_populate_sysroot"
+ file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch \
+"