summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-23 14:15:01 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-23 14:24:23 +0200
commitfa5d1ecd28f517e26b0bef2749afe3e337d919a9 (patch)
treee3c2b2d528942a6412264d1d4df7dae545f8f030 /meta-agl-profile-graphical
parent01fc2156dd1ffc90776369e1c4ab5acf0f221ed0 (diff)
Move hmi-framework and eg-virt from meta-agl-devel to meta-agl
Part of the layer cleanup. Bug-AGL: SPEC-2450 Change-Id: I0e0517c6f5aeaa1378715acde8adda6200119aba Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical')
-rw-r--r--meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb14
-rw-r--r--meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb33
-rw-r--r--meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf4
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug8
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb19
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf16
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb26
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb15
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb16
9 files changed, 151 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb b/meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb
new file mode 100644
index 000000000..6b250f839
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Homescreen binding and client library for application"
+DESCRIPTION = "agl-service-homescreen is the binding library"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen"
+SECTION = "HMI"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "dbus glib-2.0 af-binder json-c"
+
+inherit cmake aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "6c3015a7607c45313fa10792b9914864f8c25831"
+S = "${WORKDIR}/git"
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb
new file mode 100644
index 000000000..9be3550c9
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Window Manager service binding for applications"
+DESCRIPTION = "Window Manager is the service binding for controlling \
+ rendering rights. Applications request to render itself, \
+ then Window Manager checks the policy and notifies the \
+ layout to the respective applications \
+ "
+HOMEPAGE = "https://wiki.automotivelinux.org/windowmanager"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS = "af-binder json-c wayland wayland-ivi-extension"
+
+inherit cmake aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH} \
+ file://weston-ready.conf \
+"
+SRCREV = "b6644e5cffa84e40d62e38f4ee0c14e64e0faf48"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # Install systemd over-ride that adds a dependency on weston-ready
+ # to ensure that the windowmanager and its dependencies start after
+ # weston is actually initialized.
+ install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+ install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+REDEPENDS_${PN} += "weston-ready"
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf
new file mode 100644
index 000000000..e90eed5f8
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf
@@ -0,0 +1,4 @@
+[Unit]
+Requires=weston-ready.service
+After=weston-ready.service
+
diff --git a/meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug
new file mode 100644
index 000000000..fee9573b7
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug
@@ -0,0 +1,8 @@
+#You can select log level of HMI framework
+#1 ERROR
+#2 WARNING
+#3 NOTICE
+#4 INFO
+#5 DEBUG
+#If you want to output debug log about hmi-framework, please uncomment the following.
+#USE_HMI_DEBUG=5
diff --git a/meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb
new file mode 100644
index 000000000..27fb60d66
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Configurations for HMI framework"
+
+SECTION = "HMI"
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = " \
+ file://hmi-debug \
+"
+
+FILES_${PN} = " \
+ ${sysconfdir}/afm/unit.env.d \
+"
+
+do_install() {
+ install -d ${D}${sysconfdir}/afm/unit.env.d
+ install -m 644 ${WORKDIR}/hmi-debug ${D}${sysconfdir}/afm/unit.env.d
+}
diff --git a/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf
new file mode 100644
index 000000000..dc3852eee
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf
@@ -0,0 +1,16 @@
+<!DOCTYPE busconfig PUBLIC
+"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+ <policy context="default">
+ <!-- Allow everyone to talk to main service. We'll later add an agent to
+ only share the location if user allows it. -->
+ <allow send_interface="org.agl.statusbar"/>
+ </policy>
+
+ <policy user="root">
+ <!-- Allow root to own the name on the bus -->
+ <allow own="org.agl.statusbar"/>
+ </policy>
+</busconfig>
+
diff --git a/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
new file mode 100644
index 000000000..1acd7af82
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "AGL Home Screen Library"
+DESCRIPTION = "libhomescreen"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "af-binder json-c"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.statusbar.conf \
+ "
+SRCREV = "44290c49e08fe52d6e3ed80720473577131090f4"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
+}
+
+RDEPENDS_${PN} = "agl-service-homescreen"
diff --git a/meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
new file mode 100644
index 000000000..04a83dd14
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Window Manager client library for applications"
+DESCRIPTION = "Window Manager client library for application built with recipe"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS = "af-binder json-c"
+RDEPENDS_${PN} = "agl-service-windowmanager"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "003cdfb640b595345b0d4d09471872c9295d0bc7"
+S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"
diff --git a/meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb b/meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb
new file mode 100644
index 000000000..d5bd568bd
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Launcher of XDG application on AGL HMI Framework (2017)"
+DESCRIPTION = "The command 'runxdg' is a launcher to execute XDG application \
+ on AGL HMI Framework which using wayland-ivi-extension"
+HOMEPAGE = "https://git.automotivelinux.org/staging/xdg-launcher"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+DEPENDS = "json-c wayland wayland-ivi-extension libhomescreen libwindowmanager"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/xdg-launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"