summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-04-13 15:58:12 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-04-14 16:32:18 +0000
commitc407a33fe8d808e4c1c6a15a524de179e658c696 (patch)
tree3e855f411e91341195146aeca7de84f6ee3d8de1 /meta-agl/recipes-core
parent0d4cff7d5839e501ab16f0dbe21c18620616d5b0 (diff)
Select networking manager with VIRTUAL-RUNTIME_net_manager at distro level
This variable allows to select the network manager daemon to use in the distro. Possible values are: systemd, connman. Later, it's possible to add other network daemons as well. Change-Id: I4085b4459d3ea110513f6ca9b921c5da92a7d745 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-core')
-rw-r--r--meta-agl/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bb1
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend13
2 files changed, 10 insertions, 4 deletions
diff --git a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bb b/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bb
index 54a154d72..e909d5e5f 100644
--- a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bb
+++ b/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bb
@@ -11,4 +11,5 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
dhcp-server \
+ ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client connman-tests connman-tools connman-ncurses','',d)} \
"
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index 96ca6c69d..ef877c0c1 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -1,17 +1,22 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://e2fsck.conf \
- file://wired.network \
+ ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
"
# enable networkd/resolved support
-PACKAGECONFIG_append_pn-systemd = " networkd resolved"
+PACKAGECONFIG_append_pn-systemd = " \
+ ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','networkd resolved','',d)} \
+"
do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
- # Install DHCP configuration for Ethernet adapters
- install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
+
+ if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
+ # Install DHCP configuration for Ethernet adapters
+ install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
+ fi
}
FILES_${PN} += "${sysconfdir}/e2fsck.conf "