summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-multimedia
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-02-03 10:55:14 +0000
committerManuel Bachmann <mbc@iot.bzh>2016-02-03 11:12:46 +0000
commit2a50a1ee20d39db50b700e53a550985d69a984a5 (patch)
treec1c0548f75359ca346672717520f14ba52552e27 /meta-agl/recipes-multimedia
parentf59c808ae7f7e02dced00d56ef2cbb0acc8a4eb1 (diff)
Remove Yocto 1.7 compatibility crufts
As we are now based upon Yocto 2.0, we can remove lots of backported recipes and contextual patches, which only made sense in the context of Yocto 1.7. Here is the rationale behind each change: - gupnp-dlna: already in meta-openembedded/jethro - ofono: BlueZ 5 compatibility is now working - rygel: already in meta-openembedded/jethro - libgee: already in meta-openembedded/jethro - pulseaudio: BlueZ 5 compatibility is now working - lightmediascanner: already in meta-openembedded/jethro - gpsd: BlueZ 5 compatibility is now working - libmediaart: already in meta-openembedded/jethro - gtest: already in meta-openembedded/jethro - wayland-fits: already in meta-openembedded/jethro PS: "meta-openembedded/meta-efl" is now required because we require the "lightmediascanner" recipe, which is unrelated to EFL but happens to live there. Change-Id: Ib46d152f80b1a8ee5cf848a41e408ece28e6ec65 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-multimedia')
-rw-r--r--meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch11
-rw-r--r--meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb62
-rw-r--r--meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend6
3 files changed, 0 insertions, 79 deletions
diff --git a/meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch b/meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch
deleted file mode 100644
index 9528bec79..000000000
--- a/meta-agl/recipes-multimedia/lightmediascanner/files/id3-plugin-support-out-of-tree-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/plugins/Makefile.am 2015-10-25 16:12:29.331415823 +0000
-+++ b/src/plugins/Makefile.am 2015-10-25 16:14:37.593415808 +0000
-@@ -93,7 +93,7 @@
- id3_id3_la_SOURCES = id3/id3.c id3/id3v1_genres.c
- id3_id3_la_LIBADD = $(PLUGINS_LIBADD)
-
--id3/id3v1_genres.c: $(srcdir)/id3/id3v1_genres.def $(srcdir)/id3/id3v1_genres_gen.awk
-+$(srcdir)/id3/id3v1_genres.c: $(srcdir)/id3/id3v1_genres.def $(srcdir)/id3/id3v1_genres_gen.awk
- $(AWK) -f $(srcdir)/id3/id3v1_genres_gen.awk $(srcdir)/id3/id3v1_genres.def > $@
-
- EXTRA_DIST += id3/id3v1_genres.def id3/id3v1_genres_gen.awk
diff --git a/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb b/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
deleted file mode 100644
index 9870fac3d..000000000
--- a/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
+++ /dev/null
@@ -1,62 +0,0 @@
-SUMMARY = "Lightweight media scanner"
-DESCRIPTION = "Lightweight media scanner meant to be used in not-so-powerful devices, like embedded systems or old machines."
-SECTION = "libs/multimedia"
-
-LICENSE = "LGPLv2.1+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
- file://src/lib/lightmediascanner.c;endline=21;md5=6d8889bccb4c6c27e8b786342a3eb267"
-
-DEPENDS = "file gawk glib-2.0 sqlite3"
-
-PV = "0.5.1+git${SRCPV}"
-SRCREV = "adfddb3486276a5ed2f5008c9e43a811e1271cc9"
-SRC_URI = "git://github.com/profusion/lightmediascanner.git \
- file://id3-plugin-support-out-of-tree-build.patch \
- "
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--enable-static --disable-mp4"
-
-PACKAGECONFIG ??= "ogg flac wave id3 m3u pls asf rm jpeg png"
-PACKAGECONFIG[generic] = "--enable-generic,--disable-generic,libav"
-PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg libvorbis libtheora"
-PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
-PACKAGECONFIG[wave] = "--enable-wave,--disable-wave"
-PACKAGECONFIG[id3] = "--enable-id3,--disable-id3"
-PACKAGECONFIG[m3u] = "--enable-m3u,--disable-m3u"
-PACKAGECONFIG[pls] = "--enable-pls,--disable-pls"
-PACKAGECONFIG[asf] = "--enable-asf,--disable-asf"
-PACKAGECONFIG[rm] = "--enable-rm,--disable-rm"
-PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg"
-PACKAGECONFIG[png] = "--enable-png,--disable-png"
-
-do_install_append() {
- # Install "test" binary for corresponding package
- install -d ${D}/${bindir}
- install -m 755 ${B}/src/bin/.libs/test ${D}/${bindir}/test-lms
- # Remove .la files for loadable modules
- rm -f ${D}/${libdir}/${PN}/plugins/*.la
-}
-
-FILES_${PN} += "${datadir}/dbus-1"
-FILES_${PN}-dbg += "${libdir}/${PN}/plugins/.debug"
-
-PACKAGES_prepend = "${PN}-test "
-FILES_${PN}-test_prepend = "${bindir}/test-lms "
-
-PACKAGES += "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
-
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
-
-python populate_packages_prepend () {
- lms_libdir = d.expand('${libdir}/${PN}')
- pkgs = []
-
- pkgs += do_split_packages(d, oe.path.join(lms_libdir, "plugins"), '^(.*)\.so$', d.expand('${PN}-plugin-%s'), 'LightMediaScanner plugin for %s', prepend=True, extra_depends=d.expand('${PN}'))
- metapkg = d.getVar('PN', True) + '-meta'
- d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
-}
diff --git a/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
deleted file mode 100644
index fd7b84986..000000000
--- a/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Prevent BlueZ 4 from being always pulled
-PACKAGECONFIG_remove = "bluez4"
-
-# If Bluetooth is asked in DISTRO_FEATURES, verify if Bluez 5 is also
-# explicitly specified. If it is not, fall back to BlueZ 4
-PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5', 'bluez4', d), '', d)}"