summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-02-03 10:55:14 +0000
committerManuel Bachmann <mbc@iot.bzh>2016-02-03 11:12:46 +0000
commit2a50a1ee20d39db50b700e53a550985d69a984a5 (patch)
treec1c0548f75359ca346672717520f14ba52552e27 /meta-ivi-common
parentf59c808ae7f7e02dced00d56ef2cbb0acc8a4eb1 (diff)
Remove Yocto 1.7 compatibility crufts
As we are now based upon Yocto 2.0, we can remove lots of backported recipes and contextual patches, which only made sense in the context of Yocto 1.7. Here is the rationale behind each change: - gupnp-dlna: already in meta-openembedded/jethro - ofono: BlueZ 5 compatibility is now working - rygel: already in meta-openembedded/jethro - libgee: already in meta-openembedded/jethro - pulseaudio: BlueZ 5 compatibility is now working - lightmediascanner: already in meta-openembedded/jethro - gpsd: BlueZ 5 compatibility is now working - libmediaart: already in meta-openembedded/jethro - gtest: already in meta-openembedded/jethro - wayland-fits: already in meta-openembedded/jethro PS: "meta-openembedded/meta-efl" is now required because we require the "lightmediascanner" recipe, which is unrelated to EFL but happens to live there. Change-Id: Ib46d152f80b1a8ee5cf848a41e408ece28e6ec65 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch55
-rw-r--r--meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch39
-rw-r--r--meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb23
-rw-r--r--meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb33
4 files changed, 0 insertions, 150 deletions
diff --git a/meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch b/meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
deleted file mode 100644
index 1ece136b6..000000000
--- a/meta-ivi-common/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From d4b25ce723812faf78d8ee038b7cbed00cbba682 Mon Sep 17 00:00:00 2001
-From: Rodrigo Caimi <caimi@datacom.ind.br>
-Date: Tue, 7 Oct 2014 15:37:10 -0300
-Subject: [PATCH] CMakeLists, gtest.pc.in: Add pkg-config support to gtest
- 1.7.0
-
-Signed-off-by: Rodrigo Caimi <caimi@datacom.ind.br>
----
- CMakeLists.txt | 6 ++++++
- gtest.pc.in | 9 +++++++++
- 2 files changed, 15 insertions(+)
- create mode 100644 gtest.pc.in
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 281c4c2..e4354a8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -29,6 +29,9 @@ if (COMMAND pre_project_set_up_hermetic_build)
- pre_project_set_up_hermetic_build()
- endif()
-
-+# pkg-config support
-+configure_file("gtest.pc.in" "gtest.pc" @ONLY)
-+
- ########################################################################
- #
- # Project-wide settings
-@@ -75,6 +78,9 @@ target_link_libraries(gtest_main gtest)
-
- install(TARGETS gtest DESTINATION lib)
- install(TARGETS gtest_main DESTINATION lib)
-+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gtest.pc"
-+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig/"
-+)
-
- ########################################################################
- #
-diff --git a/gtest.pc.in b/gtest.pc.in
-new file mode 100644
-index 0000000..57b1049
---- /dev/null
-+++ b/gtest.pc.in
-@@ -0,0 +1,9 @@
-+Name: libgtest
-+Version: 1.7.0
-+Description: Google's framework for writing C++ tests on a variety of platforms
-+
-+prefix=@CMAKE_INSTALL_PREFIX@
-+includedir=${prefix}/include
-+libdir=${prefix}/lib
-+Cflags:-I${includedir}/gtest
-+Libs: -L${libdir} -lgtest -lgtest_main
---
-1.9.1
-
diff --git a/meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch b/meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
deleted file mode 100644
index 0c160b02a..000000000
--- a/meta-ivi-common/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 5318983562be6babeb5a6996e7dda4b31acfdba8 Mon Sep 17 00:00:00 2001
-From: Otavio Salvador <otavio@ossystems.com.br>
-Date: Wed, 30 Jul 2014 16:49:53 -0300
-Subject: [PATCH] cmake: Add install command for libraries and headers
-Organization: O.S. Systems Software LTDA.
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 57470c8..281c4c2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -56,6 +56,8 @@ include_directories(
- ${gtest_SOURCE_DIR}/include
- ${gtest_SOURCE_DIR})
-
-+install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest DESTINATION include)
-+
- # Where Google Test's libraries can be found.
- link_directories(${gtest_BINARY_DIR}/src)
-
-@@ -71,6 +73,9 @@ cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
- cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
- target_link_libraries(gtest_main gtest)
-
-+install(TARGETS gtest DESTINATION lib)
-+install(TARGETS gtest_main DESTINATION lib)
-+
- ########################################################################
- #
- # Samples on how to link user tests with gtest or gtest_main.
---
-1.9.1
-
diff --git a/meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb b/meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb
deleted file mode 100644
index 9f148d549..000000000
--- a/meta-ivi-common/recipes-test/gtest/gtest_1.7.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Google's framework for writing C++ tests"
-HOMEPAGE = "http://code.google.com/p/googletest/"
-SECTION = "libs"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
-
-SRC_URI = "\
- http://googletest.googlecode.com/files/${BPN}-${PV}.zip \
- file://cmake-Add-install-command-for-libraries-and-headers.patch \
- file://CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch \
-"
-
-SRC_URI[md5sum] = "2d6ec8ccdf5c46b05ba54a9fd1d130d7"
-SRC_URI[sha256sum] = "247ca18dd83f53deb1328be17e4b1be31514cedfc1e3424f672bf11fd7e0d60d"
-
-inherit lib_package cmake
-
-ALLOW_EMPTY_${PN} = "1"
-ALLOW_EMPTY_${PN}-dbg = "1"
-
-RDEPENDS_${PN}-dev += "${PN}-staticdev"
-
-BBCLASSEXTEND = "nativesdk"
diff --git a/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb b/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb
deleted file mode 100644
index 3a4f8a2ca..000000000
--- a/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "Wayland-fits, the Wayland Functional Integration Test Suite"
-DESCRIPTION = "Wayland-fits is a fully automated functional integration \
-test suite. Its main purpose is to test the functionality and integration of \
-client-side (i.e. toolkit) and server-side (compositor) implementations of \
-the Wayland protocol."
-HOMEPAGE = "https://github.com/01org/wayland-fits"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=f8d34cadaf891753c0f00c6cd48f08f5 \
- file://src/extensions/weston/weston-wfits.cpp;endline=21;md5=848c81e55cf3a30a9f6ed75f0dba7a97"
-
-SRC_URI = "git://github.com/01org/wayland-fits.git"
-SRCREV = "f30dfa9fceb438d3687c5215093fffc21a7852fc"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-DEPENDS = "libcheck boost wayland weston"
-RDEPENDS_${PN} = "weston"
-
-EXTRA_OECONF += "--enable-shared --disable-static --with-boost-libdir=${STAGING_LIBDIR}"
-
-PACKAGECONFIG ??= "elementary gtk+3"
-
-PACKAGECONFIG[elementary] = "--enable-efl-tests,--disable-efl-tests,elementary"
-PACKAGECONFIG[gtk+3] = "--enable-gtk-tests,--disable-gtk-tests,gtk+3"
-
-do_install_append() {
- rm -f ${D}/${libdir}/weston/*.la
-}
-
-FILES_${PN} += "${bindir}/wfits ${libdir}/weston/*.so"
-FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/weston/.debug ${prefix}/src"