summaryrefslogtreecommitdiffstats
path: root/meta-netboot/recipes-core/systemd
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 07:37:25 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-05-24 13:54:15 +0000
commit27ef613ed0e25783ab7e8c77f56ff8c82d37f9d5 (patch)
tree26219a296caba7fa51d9618b4997a8754ac8e9bd /meta-netboot/recipes-core/systemd
parentfdcc0542bcdb1a5f26e4e4fae0828ab7bb3582f6 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I32e277e15e5aa1ac93dadc67199dedd148d3d0b9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-netboot/recipes-core/systemd')
-rw-r--r--meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
index 36d096b44..6180b78c2 100644
--- a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
+++ b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "file://resolv-conf-relabel.service"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd allarch features_check
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -15,7 +18,7 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
}
FILES:${PN} += "${systemd_system_unitdir}"