summaryrefslogtreecommitdiffstats
path: root/meta-netboot/recipes-core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-netboot/recipes-core/systemd')
-rw-r--r--meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
index 36d096b44..6180b78c2 100644
--- a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
+++ b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "file://resolv-conf-relabel.service"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd allarch features_check
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -15,7 +18,7 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
}
FILES:${PN} += "${systemd_system_unitdir}"