summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-core/recipes-core')
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb7
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd_aglcore.inc6
2 files changed, 8 insertions, 5 deletions
diff --git a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
index a23cd839a..1624aea38 100644
--- a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
+++ b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
@@ -13,16 +13,19 @@ SRC_URI = "\
file://canbus-can.link \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
CANBUS_NETWORK_CONFIG ??= "canbus-can.network"
CANBUS_NETWORK_CONFIG:virtio-all ?= "canbus-virtio.network"
do_install() {
# Install CAN bus network configuration
install -d ${D}${nonarch_base_libdir}/systemd/network/
- install -m 0644 ${WORKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
+ install -m 0644 ${UNPACKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
# Install link configuration to bump queue size on physical CAN bus devices
- install -m 0644 ${WORKDIR}/canbus-can.link ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.link
+ install -m 0644 ${UNPACKDIR}/canbus-can.link ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.link
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc b/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
index 9681329be..9fbe23708 100644
--- a/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
+++ b/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
@@ -20,15 +20,15 @@ PACKAGECONFIG:append:agl-devel = " coredump"
do_install:append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+ install -m 644 -p -D ${UNPACKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
if [ "${VIRTUAL-RUNTIME_net_manager}" = "systemd" ]; then
# Install DHCP configuration for Ethernet adapters
- install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
+ install -m 644 ${UNPACKDIR}/wired.network ${D}${sysconfdir}/systemd/network
elif [ "${VIRTUAL-RUNTIME_net_manager}" = "connman" ]; then
# Disable systemd-networkd-wait-online by default
install -d ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d
- install -m 0644 ${WORKDIR}/wait-disable.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
+ install -m 0644 ${UNPACKDIR}/wait-disable.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
fi
}