summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index 29b7d1d7e..ef926953c 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -1,3 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://e2fsck.conf "
+
# enable networkd support
PACKAGECONFIG_append_pn-systemd = " networkd"
+do_install_append() {
+ # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
+ install -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+}
+
+FILES_${PN} += " /etc/e2fsck.conf "