summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-core/systemd')
-rw-r--r--meta-agl/recipes-core/systemd/systemd/e2fsck.conf3
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend10
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-agl/recipes-core/systemd/systemd/e2fsck.conf b/meta-agl/recipes-core/systemd/systemd/e2fsck.conf
new file mode 100644
index 000000000..b774f9ebf
--- /dev/null
+++ b/meta-agl/recipes-core/systemd/systemd/e2fsck.conf
@@ -0,0 +1,3 @@
+[options]
+# This will prevent e2fsck from stopping boot just because the clock is wrong
+broken_system_clock = 1
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index 29b7d1d7e..ef926953c 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -1,3 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://e2fsck.conf "
+
# enable networkd support
PACKAGECONFIG_append_pn-systemd = " networkd"
+do_install_append() {
+ # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
+ install -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+}
+
+FILES_${PN} += " /etc/e2fsck.conf "