summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-23 14:15:01 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-23 14:24:23 +0200
commitfa5d1ecd28f517e26b0bef2749afe3e337d919a9 (patch)
treee3c2b2d528942a6412264d1d4df7dae545f8f030 /meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
parent01fc2156dd1ffc90776369e1c4ab5acf0f221ed0 (diff)
Move hmi-framework and eg-virt from meta-agl-devel to meta-agl
Part of the layer cleanup. Bug-AGL: SPEC-2450 Change-Id: I0e0517c6f5aeaa1378715acde8adda6200119aba Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
new file mode 100644
index 000000000..1acd7af82
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "AGL Home Screen Library"
+DESCRIPTION = "libhomescreen"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "af-binder json-c"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.statusbar.conf \
+ "
+SRCREV = "44290c49e08fe52d6e3ed80720473577131090f4"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
+}
+
+RDEPENDS_${PN} = "agl-service-homescreen"